[clang] Implement lifetime analysis for lifetime_capture_by(X) (#115921)
[llvm-project.git] / clang / test / CXX / except / except.spec / p9-noexcept.cpp
blob74161a50bd3a4994e9fae949991a6dfca204405e
1 // RUN: %clang_cc1 %s -std=c++11 -triple=x86_64-apple-darwin10 -emit-llvm -o - -fcxx-exceptions -fexceptions | FileCheck %s
3 void external();
5 void target() noexcept
7 // CHECK: invoke void @_Z8externalv()
8 external();
10 // CHECK: [[T0:%.*]] = landingpad { ptr, i32 }
11 // CHECK-NEXT: catch ptr null
12 // CHECK-NEXT: [[T1:%.*]] = extractvalue { ptr, i32 } [[T0]], 0
13 // CHECK-NEXT: call void @__clang_call_terminate(ptr [[T1]]) [[NR_NUW:#[0-9]+]]
14 // CHECK-NEXT: unreachable
16 void reverse() noexcept(false)
18 // CHECK: call void @_Z8externalv()
19 external();
22 // CHECK: attributes [[NR_NUW]] = { noreturn nounwind }