20 hostname = config.networking.hostName;
24 www-urls = config.lib.wwwURLs or { };
26 get-url = url-or-attrs:
27 if ! isAttrs url-or-attrs then url-or-attrs
28 else url-or-attrs.url;
30 get-cfg = url-or-attrs:
31 if ! isAttrs url-or-attrs then ""
35 if k == "url" then acc
36 else acc + "${k} ${v};\n"
41 services.nginx = maybe' {
42 enable = trace "Nginx for www.func.xyz Enabled" true;
43 virtualHosts."www.func.xyz" = {
47 (location: url-or-attrs:
48 nameValuePair location {
49 proxyPass = "${get-url url-or-attrs}$is_args$args";
52 proxy_ssl_trusted_certificate ${pkgs.cacert}/etc/ssl/certs/ca-bundle.crt;
53 proxy_ssl_session_reuse on;
54 proxy_ssl_server_name on;
55 proxy_set_header Host $host;
56 proxy_set_header X-Real-IP $remote_addr;
57 proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
58 proxy_set_header X-Forwarded-Proto $scheme;
59 proxy_set_header X-Forwarded-Host $host;
60 proxy_set_header X-Forwarded-Server $host;
62 '' + get-cfg url-or-attrs;
67 security.acme = maybe' {
70 "www.func.xyz".email = "thomas.cat@func.xyz";