move ebuild for a clean diff
[portage-prefix-bleeding-edge-ebuilds.git] / sys-apps / texinfo / texinfo-4.13a.ebuild
blob9f6d43643d85371df3e7d9438fe6419561a90725
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/texinfo-4.12.ebuild,v 1.1 2008/05/05 04:24:49 vapier Exp $
5 EAPI="prefix"
7 inherit flag-o-matic
9 DESCRIPTION="The GNU info program and utilities"
10 HOMEPAGE="http://www.gnu.org/software/texinfo/"
11 SRC_URI="mirror://gnu/${PN}/${P}.tar.lzma"
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~ppc-aix ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
16 IUSE="nls static"
18 RDEPEND="!=app-text/tetex-2*
19 >=sys-libs/ncurses-5.2-r2
20 nls? ( virtual/libintl )"
21 DEPEND="${RDEPEND}
22 app-arch/lzma-utils
23 nls? ( sys-devel/gettext )
24 sys-apps/help2man"
26 S="${WORKDIR}"/${PN}-4.13
27 src_compile() {
28 use static && append-ldflags -static
29 econf $(use_enable nls) || die
30 emake || die "emake"
33 src_install() {
34 emake DESTDIR="${D}" install || die "install failed"
36 dodoc AUTHORS ChangeLog INTRODUCTION NEWS README TODO
37 newdoc info/README README.info
38 newdoc makeinfo/README README.makeinfo
40 rm -f "${ED}"/usr/lib/charset.alias #195148