1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20080725.ebuild,v 1.1 2008/10/02 02:59:30 darkside Exp $
7 inherit eutils flag-o-matic toolchain-funcs autotools
12 LOCALE_RELEASE
="2008-07-25"
13 INIT_RELEASE
="${RELEASE}"
15 DESCRIPTION
="The Original Korn Shell, 1993 revision (ksh93)"
16 HOMEPAGE
="http://www.kornshell.com/"
17 SRC_URI
="nls? ( mirror://gentoo/ast-ksh-locale.${LOCALE_RELEASE}.tgz )
18 INIT.${INIT_RELEASE}.tgz
19 ast-ksh.${RELEASE}.tgz"
20 #mirror://gentoo/INIT.${INIT_RELEASE}.tgz
21 #mirror://gentoo/ast-ksh.${RELEASE}.tgz"
25 KEYWORDS
="~x86-interix ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris ~sparc64-solaris"
28 DEPEND
="!app-shells/pdksh"
31 einfo
"Please download"
32 einfo
" - INIT.${INIT_RELEASE}.tgz"
33 einfo
" - ast-ksh.${RELEASE}.tgz"
34 einfo
"from http://www.research.att.com/sw/download/ and place them"
40 # the AT&T build tools look in here for packages.
41 mkdir
-p ${S}/lib
/package
/tgz
43 # move the packages into place.
44 cp ${DISTDIR}/ast-ksh.${RELEASE}.tgz ${S}/lib
/package
/tgz
/ || die
47 cp ${DISTDIR}/ast-ksh-locale.${LOCALE_RELEASE}.tgz ${S}/lib
/package
/tgz
/ || die
50 # INIT provides the basic tools to start building.
51 unpack INIT.
${INIT_RELEASE}.tgz
53 # `package read` will unpack any tarballs put in place.
54 ${S}/bin
/package
read || die
56 epatch
"${FILESDIR}/${PN}-93.20080725-darwin-jobs.patch"
57 epatch
"${FILESDIR}/${PN}-prefix.patch"
58 eprefixify src
/cmd
/ksh93
/data
/msg.c
62 strip-flags
; export CCFLAGS
="${CFLAGS}"
64 cd ${S}; .
/bin
/package only
make ast-ksh CC
="$(tc-getCC)" || die
66 # install the optional locale data.
68 cd ${S}; .
/bin
/package only
make ast-ksh-locale CC
="$(tc-getCC)"
75 doexe
${S}/arch
/*.
*/bin
/ksh || die
77 newman
${S}/arch
/*.
*/man
/man
1/sh
.1 ksh
.1
79 dodoc lib
/package
/LICENSES
/ast
80 dohtml lib
/package
/ast-ksh.html
84 mv ${S}/share
/lib
/locale
${ED}/usr
/share
85 find ${ED}/usr
/share
/locale
-type f
-name 'LC_TIME' -exec rm -rf {} \
; 2>/dev
/null