remove EAPI=6 ebuilds that are superceded
[sgilles-overlay.git] / dev-libs / skalibs / skalibs-2.3.10.0.ebuild
blob35c6b3cd19919b81ee5c4f02bfe4d91fc409922c
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
5 EAPI=6
7 inherit multilib
9 DESCRIPTION="development files used for building software at skarnet.org: essentially general-purpose libraries"
10 HOMEPAGE="http://www.skarnet.org/software/skalibs/index.html"
11 SRC_URI="http://www.skarnet.org/software/${PN}/${P}.tar.gz"
13 LICENSE="ISC"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86 ~arm"
16 IUSE="doc ipv6 static-libs"
18 DEPEND=">=sys-devel/make-3.81"
19 RDEPEND=""
21 src_prepare() {
22 # Remove QA warning about LDFLAGS addition
23 sed -i "s~tryldflag LDFLAGS_AUTO -Wl,--hash-style=both~:~" "${S}/configure" || die
25 eapply_user
28 src_configure() {
29 econf \
30 $(use_enable ipv6) \
31 $(use_enable static-libs static) \
32 --dynlibdir=/$(get_libdir) \
33 --libdir=/usr/$(get_libdir)/${PN} \
34 --datadir=/etc \
35 --sysdepdir=/usr/$(get_libdir)/${PN} \
36 --enable-force-devr
39 src_install() {
40 default
41 dodir /etc/ld.so.conf.d/
42 echo "/$(get_libdir)/${PN}" > ${ED}/etc/ld.so.conf.d/10${PN}.conf || die
44 use doc && dohtml -r doc/*