dev-libs/wayland: remove, obsolete
[sgilles-overlay.git] / sci-libs / qd / qd-2.3.14.ebuild
blob88fd218ca1b49fc8f01f6c33cd41e028b8e0336d
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sci-libs/qd/qd-2.3.14.ebuild,v 1.1 2013/05/31 12:30:18 jlec Exp $
5 EAPI=5
7 AUTOTOOLS_AUTORECONF=yes
9 FORTRAN_NEEDED=fortran
11 inherit autotools-utils fortran-2
13 DESCRIPTION="Quad-double and double-double float arithmetics"
14 HOMEPAGE="http://crd.lbl.gov/~dhbailey/mpdist/"
15 SRC_URI="http://crd.lbl.gov/~dhbailey/mpdist/${P}.tar.gz"
17 SLOT="0"
18 LICENSE="BSD"
19 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
20 IUSE="doc fortran static-libs"
22 PATCHES=( "${FILESDIR}"/${PN}-2.3.13-autotools.patch
23 "${FILESDIR}"/${PN}-2.3.14-SnapPy.patch
26 src_configure() {
27 local myeconfargs=(
28 $(use_enable fortran enable_fortran)
30 autotools-utils_src_configure
33 src_install() {
34 autotools-utils_src_install
36 use doc || rm "${ED}"/usr/share/doc/${PF}/*.pdf
37 dosym qd_real.h /usr/include/qd/qd.h
38 dosym dd_real.h /usr/include/qd/dd.h