app-i18n/yaft: add the patch to redraw less of the screen, sometimes
[sgilles-overlay.git] / app-text / fbpdf / fbpdf-0_p20161202-r2.ebuild
blob19c754537ae0fb28732fef431908b76e0e6d86e0
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
5 EAPI=6
7 inherit toolchain-funcs
9 DESCRIPTION="framebuffer pdf and djvu viewer"
10 HOMEPAGE="http://repo.or.cz/fbpdf.git"
11 SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.gz"
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86 ~arm"
16 IUSE="djvu libressl"
18 RDEPEND="
19 >=app-text/mupdf-1.10:0=
20 media-libs/freetype:2=
21 media-libs/jbig2dec:0=
22 virtual/jpeg:0=
23 media-libs/openjpeg:0=
24 !libressl? ( dev-libs/openssl:0= )
25 libressl? ( dev-libs/libressl:0= )
26 djvu? ( app-text/djvu:0= )
29 DEPEND="${RDEPEND}"
31 S=${WORKDIR}/${PN}
33 PATCHES=(
34 "${FILESDIR}"/${P}-format.patch
35 "${FILESDIR}"/${P}-use-pkg-config.patch
38 src_compile() {
39 emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" fbpdf
40 use djvu && emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" fbdjvu
43 src_install() {
44 dobin fbpdf
45 use djvu && dobin fbdjvu
46 dodoc README