1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
9 if [[ ${PV} == "9999" ]] ; then
10 EGIT_REPO_URI
="git://linux-nfs.org/~steved/rpcbind.git"
11 inherit autotools git-r3
13 SRC_URI
="mirror://sourceforge/${PN}/${P}.tar.bz2"
14 KEYWORDS
="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
17 DESCRIPTION
="portmap replacement which supports RPC over various protocols"
18 HOMEPAGE
="http://sourceforge.net/projects/rpcbind/"
22 IUSE
="debug selinux systemd tcpd warmstarts"
24 CDEPEND
=">=net-libs/libtirpc-0.2.3:=
25 systemd? ( sys-apps/systemd:= )
26 tcpd? ( sys-apps/tcp-wrappers )"
30 selinux? ( sec-policy/selinux-rpcbind )"
33 [[ ${PV} == "9999" ]] && eautoreconf
34 epatch
"${FILESDIR}"/${P}-libtirpc.
patch
35 epatch
"${FILESDIR}"/${P}-mem-corrupt.
patch #560990
36 epatch
"${FILESDIR}/${P}-avoid-cdefs.h.patch"
37 epatch
"${FILESDIR}/${P}-make-musl-happier.patch"
43 --bindir="${EPREFIX}"/sbin \
44 --with-statedir="${EPREFIX}"/run
/${PN} \
46 --with-systemdsystemunitdir=$
(usex systemd
"$(systemd_get_unitdir)" "no") \
47 $
(use_enable tcpd libwrap
) \
49 $
(use_enable warmstarts
)
55 newinitd
"${FILESDIR}"/${PN}.initd ${PN}
56 newconfd "${FILESDIR}"/${PN}.confd ${PN}
58 systemd_dounit
"${FILESDIR}"/${PN}.service