Tweaked gesture to be a simple l-r or r-l
[shopper.git] / debian / rules
blob6416d629024271134238ff1ab10bf5534919947a
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 export DH_VERBOSE=1
12 APPNAME := shopper
13 builddir:
14 mkdir -p builddir
16 builddir/Makefile: builddir
17 cd builddir && qmake-qt4 PREFIX=/usr ../$(APPNAME).pro
19 build: build-stamp
21 build-stamp: builddir/Makefile
22 dh_testdir
24 # Add here commands to compile the package.
25 cd builddir && $(MAKE)
26 #docbook-to-man debian/$(APPNAME).sgml > $(APPNAME).1
28 touch $@
30 clean:
31 dh_testdir
32 dh_testroot
33 rm -f build-stamp
35 # Add here commands to clean up after the build process.
36 rm -rf builddir
38 dh_clean
40 install: build
41 dh_testdir
42 dh_testroot
43 dh_clean -k
44 dh_installdirs
46 # Add here commands to install the package into debian/arora.
47 cd builddir && $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install
50 # Build architecture-independent files here.
51 binary-indep: build install
52 # We have nothing to do by default.
54 # Build architecture-dependent files here.
55 binary-arch: build install
56 dh_testdir
57 dh_testroot
58 dh_installdocs
59 dh_installexamples
60 dh_installman
61 dh_install
62 dh_link
63 dh_strip
64 dh_compress
65 dh_fixperms
66 dh_installdeb
67 dh_shlibdeps
68 dh_gencontrol
69 dh_md5sums
70 dh_builddeb
72 binary: binary-indep binary-arch
73 .PHONY: build clean binary-indep binary-arch binary install configure