3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
16 builddir
/Makefile
: builddir
17 cd builddir
&& qmake-qt4 PREFIX
=/usr ..
/$(APPNAME
).pro
21 build-stamp
: builddir
/Makefile
24 # Add here commands to compile the package.
25 cd builddir
&& $(MAKE
)
26 #docbook-to-man debian/$(APPNAME).sgml > $(APPNAME).1
35 # Add here commands to clean up after the build process.
46 # Add here commands to install the package into debian/arora.
47 cd builddir
&& $(MAKE
) INSTALL_ROOT
=$(CURDIR
)/debian
/$(APPNAME
) install
50 # Build architecture-independent files here.
51 binary-indep
: build
install
52 # We have nothing to do by default.
54 # Build architecture-dependent files here.
55 binary-arch
: build
install
72 binary
: binary-indep binary-arch
73 .PHONY
: build
clean binary-indep binary-arch binary
install configure