2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box for any current Fedora or RHEL release.
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git
20171022gitfe34eaec
14 # Increment when you generate several RPMs on the same day...
16 #------------------------------- BUILD FROM GIT -------------------------------
19 %define purple_plugin purple
-sipe
20 %define telepathy_plugin telepathy
-sipe
21 %define common_files sipe
-common
22 %define empathy_files empathy
-sipe
23 %define ktp_files ktp
-accounts
-kcm
-sipe
24 %define pkg_group Applications
/Communications
27 Summary: Pidgin protocol plugin to connect to MS Office Communicator
30 Release: %{gitcount}.%{git}%{?dist}
31 Source0: %{name}-%{git}.tar.bz2
32 # git package overrides official released package
36 Source0: http
://downloads.sourceforge.net
/project
/sipe
/sipe
/%{name}-%{version}/%{name}-%{version}.tar.bz2
40 URL: http
://sipe.sourceforge.net
/
42 BuildRequires
: pkgconfig
(dbus
-1)
43 BuildRequires
: pkgconfig
(glib
-2.0) >= 2.18.0
44 BuildRequires
: pkgconfig
(gmodule
-2.0) >= 2.18.0
45 BuildRequires
: pkgconfig
(libxml
-2.0)
46 BuildRequires
: pkgconfig
(nss
)
47 BuildRequires
: pkgconfig
(purple
) >= 2.7.0
49 BuildRequires
: autoconf
50 BuildRequires
: automake
52 BuildRequires
: gettext
53 BuildRequires
: intltool
54 BuildRequires
: libtool
55 # Use "--without vv" to disable Voice & Video features
56 %if !0%{?_without_vv:1}
57 BuildRequires
: pkgconfig
(purple
) >= 2.8.0
58 BuildRequires
: pkgconfig
(farstream
-0.2)
59 BuildRequires
: pkgconfig
(gio
-2.0)
60 BuildRequires
: pkgconfig
(gstreamer
-1.0)
61 BuildRequires
: pkgconfig
(gstreamer
-rtp
-1.0)
62 BuildRequires
: pkgconfig
(nice
) >= 0.1.0
64 # Use "--without telepathy" to disable telepathy
65 %if !0%{?_without_telepathy:1}
66 BuildRequires
: gmime
-devel
67 BuildRequires
: pkgconfig
(dbus
-glib
-1)
68 BuildRequires
: pkgconfig
(gio
-2.0) >= 2.32.0
69 BuildRequires
: pkgconfig
(glib
-2.0) >= 2.32.0
70 BuildRequires
: pkgconfig
(gobject
-2.0)
71 BuildRequires
: pkgconfig
(telepathy
-glib
) >= 0.18.0
74 # Configurable components
75 # Use "--without kerberos" to disable krb5
76 %if !0%{?_without_kerberos:1}
77 BuildRequires
: pkgconfig
(krb5
)
78 %if 0%{?fedora} || 0%{?rhel} >= 7
79 BuildRequires
: gssntlmssp
-devel
>= 0.5.0
80 %define requires_gssntlmssp
1
84 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
88 A third
-party plugin
for the Pidgin multi
-protocol instant messenger.
89 It implements the extended version of SIP
/SIMPLE used by various products
:
92 * Microsoft Office
365
93 * Microsoft Business Productivity Online Suite
(BPOS
)
94 * Microsoft Lync Server
95 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
96 * Microsoft Live Communications Server
(LCS
2003/2005)
98 With this plugin you should be able to replace your Microsoft Office
99 Communicator client with Pidgin.
101 This package provides the icon
set for Pidgin.
104 %package -n
%{purple_plugin}
105 Summary: Libpurple protocol plugin to connect to MS Office Communicator
108 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
110 %if 0%{?requires_gssntlmssp}
111 Requires: gssntlmssp
>= 0.5.0
114 %description -n
%{purple_plugin}
115 A third
-party plugin
for the Pidgin multi
-protocol instant messenger.
116 It implements the extended version of SIP
/SIMPLE used by various products
:
119 * Microsoft Office
365
120 * Microsoft Business Productivity Online Suite
(BPOS
)
121 * Microsoft Lync Server
122 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
123 * Microsoft Live Communications Server
(LCS
2003/2005)
125 This package provides the protocol plugin
for libpurple clients.
128 %if !0%{?_without_telepathy:1}
129 %package -n
%{empathy_files}
130 Summary: Telepathy connection manager to connect to MS Office Communicator
133 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
135 %description -n
%{empathy_files}
136 A Telepathy connection manager that implements the extended version of
137 SIP
/SIMPLE used by various products
:
140 * Microsoft Office
365
141 * Microsoft Business Productivity Online Suite
(BPOS
)
142 * Microsoft Lync Server
143 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
144 * Microsoft Live Communications Server
(LCS
2003/2005)
146 This package provides the icon
set for Empathy.
149 %package -n
%{ktp_files}
150 Summary: Telepathy connection manager to connect to MS Office Communicator
153 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
155 %description -n
%{ktp_files}
156 A Telepathy connection manager that implements the extended version of
157 SIP
/SIMPLE used by various products
:
160 * Microsoft Office
365
161 * Microsoft Business Productivity Online Suite
(BPOS
)
162 * Microsoft Lync Server
163 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
164 * Microsoft Live Communications Server
(LCS
2003/2005)
166 This package provides the profile
for KTP account manager.
169 %package -n
%{telepathy_plugin}
170 Summary: Telepathy connection manager to connect to MS Office Communicator
173 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
175 %if 0%{?requires_gssntlmssp}
176 Requires: gssntlmssp
>= 0.5.0
179 %description -n
%{telepathy_plugin}
180 A Telepathy connection manager that implements the extended version of
181 SIP
/SIMPLE used by various products
:
184 * Microsoft Office
365
185 * Microsoft Business Productivity Online Suite
(BPOS
)
186 * Microsoft Lync Server
187 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
188 * Microsoft Live Communications Server
(LCS
2003/2005)
190 This package provides the protocol support
for Telepathy clients.
194 %package -n
%{common_files}
195 Summary: Common files
for SIPE protocol plugins
200 %description -n
%{common_files}
201 This package provides common files
for the SIPE protocol plugins
:
208 %setup -q
-n
%{name}-%{git}
219 %if 0%{?_without_vv:1}
222 %if !0%{?_without_kerberos:1}
226 %if !0%{?_without_telepathy:1}
236 find
%{buildroot} -type f
-name "
*.la"
-delete
-print
237 # Pidgin doesn't have 24 or 32 pixel icons
239 %{buildroot}%{_datadir}/pixmaps
/pidgin
/protocols
/24/sipe.png \
240 %{buildroot}%{_datadir}/pixmaps
/pidgin
/protocols
/32/sipe.png
245 make %{?_smp_mflags} check
252 %files -n
%{purple_plugin}
253 %defattr(-,root
,root
,-)
254 %doc AUTHORS ChangeLog COPYING NEWS README TODO
255 %{_libdir}/purple
-2/libsipe.so
258 %if !0%{?_without_telepathy:1}
259 %files -n
%{empathy_files}
260 %defattr(-,root
,root
,-)
261 %{_datadir}/empathy
/icons
/hicolor
/*/apps
/im
-sipe.png
262 %{_datadir}/empathy
/icons
/hicolor
/*/apps
/im
-sipe.svg
265 %files -n
%{ktp_files}
266 %defattr(-,root
,root
,-)
268 %{_datadir}/telepathy
/profiles
/sipe.profile
271 %files -n
%{telepathy_plugin}
272 %defattr(-,root
,root
,-)
273 %doc AUTHORS ChangeLog COPYING NEWS README TODO
274 %{_datadir}/dbus
-1/services
/*.sipe.service
275 %{_libexecdir}/telepathy
-sipe
279 %files -n
%{common_files} -f %{name}.lang
280 %defattr(-,root
,root
,-)
284 %defattr(-,root
,root
,-)
285 %{_datadir}/appdata/%{name}.metainfo.xml
286 %{_datadir}/pixmaps
/pidgin
/protocols
/*/sipe.png
287 %{_datadir}/pixmaps
/pidgin
/protocols
/*/sipe.svg
291 * Sat Mar
10 2018 J. D. User
<jduser@noreply.com
> 1.23.2
294 * Sun Feb
25 2018 J. D. User
<jduser@noreply.com
> 1.23.1
297 * Sat Oct
28 2017 J. D. User
<jduser@noreply.com
> 1.23.0
299 - raise BR glib
-2.0 >= 2.18.0
300 - raise BR purple
>= 2.7.0
302 * Fri Aug
11 2017 J. D. User
<jduser@noreply.com
> 1.22.1-*git
*
305 * Sun Jun
11 2017 J. D. User
<jduser@noreply.com
> 1.22.1
308 * Wed Feb
01 2017 J. D. User
<jduser@noreply.com
> 1.22.0
311 * Sun Dec
18 2016 J. D. User
<jduser@noreply.com
> 1.21.1-*git
*
314 * Wed Jun
15 2016 J. D. User
<jduser@noreply.com
> 1.21.1-*git
*
315 - add BR farstream
-0.2
317 * Sat May
28 2016 J. D. User
<jduser@noreply.com
> 1.21.1
320 * Sat Apr
23 2016 J. D. User
<jduser@noreply.com
> 1.21.0
323 * Tue Apr
05 2016 J. D. User
<jduser@noreply.com
> 1.20.1-*git
*
324 - align with Fedora SPEC file
326 * Fri Jan
01 2016 J. D. User
<jduser@noreply.com
> 1.20.1-*git
*
327 - add AppStream metadata file
329 * Sun Nov
08 2015 J. D. User
<jduser@noreply.com
> 1.20.1-*git
*
330 - add dependency on pkgconfig
(gstreamer
-1.0) for F22
+
332 * Sat Oct
24 2015 J. D. User
<jduser@noreply.com
> 1.20.1
335 * Thu Sep
03 2015 J. D. User
<jduser@noreply.com
> 1.20.0-*git
*
336 - we also support "Skype
for Business"
338 * Sat Aug
29 2015 J. D. User
<jduser@noreply.com
> 1.20.0
341 * Sat Apr
04 2015 J. D. User
<jduser@noreply.com
> 1.19.1
344 * Sat Feb
07 2015 J. D. User
<jduser@noreply.com
> 1.19.0
347 * Tue Jan
06 2015 J. D. User
<jduser@noreply.com
> 1.18.5-*git
*
348 - add dependency on gssntlmssp
(-devel
) >= 0.5.0 for F21
+
349 - enable Voice
& Video features by default
350 - move dependency on libnice
-gstreamer to correct packages
352 * Mon Dec
29 2014 J. D. User
<jduser@noreply.com
> 1.18.5
355 * Sat Oct
18 2014 J. D. User
<jduser@noreply.com
> 1.18.4
358 * Sat Aug
16 2014 J. D. User
<jduser@noreply.com
> 1.18.3
361 * Sat Jun
07 2014 J. D. User
<jduser@noreply.com
> 1.18.2
364 * Sat Apr
12 2014 J. D. User
<jduser@noreply.com
> 1.18.1
367 * Sat Mar
08 2014 J. D. User
<jduser@noreply.com
> 1.18.0-*git
*
368 - New Fedora packaging guidelines suggest to use pkgconfig
() for BRs
370 * Tue Mar
04 2014 J. D. User
<jduser@noreply.com
> 1.18.0-*git
*
371 - F20
+ require libnice
-gstreamer
for correct operation
373 * Sat Jan
11 2014 J. D. User
<jduser@noreply.com
> 1.18.0
376 * Wed Dec
11 2013 J. D. User
<jduser@noreply.com
> 1.17.3
379 * Sat Nov
30 2013 J. D. User
<jduser@noreply.com
> 1.17.2
382 * Sat Nov
16 2013 J. D. User
<jduser@noreply.com
> 1.17.1
385 * Sat Sep
21 2013 J. D. User
<jduser@noreply.com
> 1.17.0
388 * Sat Jul
13 2013 J. D. User
<jduser@noreply.com
> 1.16.1
391 * Fri Jun
14 2013 J. D. User
<jduser@noreply.com
> 1.16.0
394 * Thu May
16 2013 J. D. User
<jduser@noreply.com
> 1.15.1-*git
*
395 - BR glib
-2.0 >= 2.28.0 no longer required
for Voice
& Video features
397 * Sun Apr
07 2013 J. D. User
<jduser@noreply.com
> 1.15.1
400 * Fri Mar
29 2013 J. D. User
<jduser@noreply.com
> 1.15.0-*git
*
401 - update package description texts
403 * Sat Mar
09 2013 J. D. User
<jduser@noreply.com
> 1.15.0
406 * Wed Dec
26 2012 J. D. User
<jduser@noreply.com
> 1.14.1
409 * Sun Dec
16 2012 J. D. User
<jduser@noreply.com
> 1.14.0
412 * Sun Sep
09 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
413 - BR telepathy
-glib
-devel
>= 0.18.0
415 * Wed Sep
05 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
416 - BR telepathy
-glib
-devel
>= 0.14.0
418 * Mon Aug
27 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
419 - add ktp
-accounts
-kcm
-sipe package
421 * Sun Aug
26 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
422 - telepathy now requires glib
-2.0 >= 2.22.0
423 - use "
--without telepathy" to disable telepathy packages
425 * Fri Aug
24 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
426 - add empathy
-sipe package
428 * Wed Aug
22 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
429 - add telepathy
-sipe
& sipe
-common packages
431 * Sun Aug
19 2012 J. D. User
<jduser@noreply.com
> 1.13.3
434 * Sun Jun
10 2012 J. D. User
<jduser@noreply.com
> 1.13.2
437 * Mon Apr
09 2012 J. D. User
<jduser@noreply.com
> 1.13.1
440 * Wed Mar
14 2012 J. D. User
<jduser@noreply.com
> 1.13.0
443 * Mon Dec
12 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
444 - we
do support Microsoft Lync Server
2010 now.
446 * Tue Dec
06 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
447 - update GPL2 license name
449 * Sat Nov
12 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
452 * Mon Oct
31 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
455 * Mon Aug
29 2011 J. D. User
<jduser@noreply.com
> 1.12.0
458 * Wed Jun
22 2011 J. D. User
<jduser@noreply.com
> 1.11.2-*git
*
459 - add "
--with vv" option to
enable Voice
& Video features
461 * Tue Nov
02 2010 J. D. User
<jduser@noreply.com
> 1.11.2
464 * Sun Oct
24 2010 J. D. User
<jduser@noreply.com
> 1.11.1
467 * Mon Oct
04 2010 J. D. User
<jduser@noreply.com
> 1.11.0
470 * Thu Sep
02 2010 J. D. User
<jduser@noreply.com
> 1.10.1-*git
*
471 - add
(commented out
) BR libnice
-devel
473 * Sun Jun
27 2010 J. D. User
<jduser@noreply.com
> 1.10.1
476 * Mon Apr
12 2010 J. D. User
<jduser@noreply.com
> 1.10.0-*git
*
477 - add
(commented out
) BR nss
-devel
479 * Sun Apr
04 2010 J. D. User
<jduser@noreply.com
> 1.10.0
482 * Sun Mar
28 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
483 - changed
--with
/--without options to
--enable/--disable
485 * Sun Mar
28 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
486 - removed
--with
-krb5 configure option as it is autodetected now
488 * Tue Mar
23 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
491 * Sat Mar
20 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
492 - add BR glib2
-devel
>= 2.12.0
494 * Wed Mar
17 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
497 * Tue Mar
16 2010 J. D. User
<jduser@noreply.com
> 1.9.1
500 * Thu Mar
11 2010 J. D. User
<jduser@noreply.com
> 1.9.0-*git
*
501 - add BR libxml2
-devel
503 * Wed Mar
10 2010 J. D. User
<jduser@noreply.com
> 1.9.0
506 * Mon Mar
08 2010 J. D. User
<jduser@noreply.com
> 1.8.1-*git
*
507 - increased libpurple build requisite to
>= 2.4.0
509 * Sun Mar
07 2010 J. D. User
<jduser@noreply.com
> 1.8.1-*git
*
510 - sync with RPM SPEC from contrib
/OBS
512 * Sat Mar
06 2010 J. D. User
<jduser@noreply.com
> 1.8.1-*git
*
513 - update package summary
& description
515 * Tue Feb
16 2010 J. D. User
<jduser@noreply.com
> 1.8.1
518 * Sun Feb
07 2010 J. D. User
<jduser@noreply.com
> 1.8.0
521 * Thu Jan
14 2010 J. D. User
<jduser@noreply.com
> 1.7.1-*git
*
522 - autogen.sh no longer runs configure
524 * Tue Dec
29 2009 J. D. User
<jduser@noreply.com
> 1.7.1-*git
*
525 - add configure parameters
for purple and telepathy
527 * Sat Dec
12 2009 J. D. User
<jduser@noreply.com
> 1.7.1-*git
*
528 - add Epoch
: for git packages to avoid update clash with official packages
530 * Thu Nov
19 2009 J. D. User
<jduser@noreply.com
> 1.7.1
533 * Wed Oct
28 2009 J. D. User
<jduser@noreply.com
> 1.7.0-*git
*
534 - add missing
Group: to purple
-sipe
536 * Mon Oct
19 2009 J. D. User
<jduser@noreply.com
> 1.7.0
539 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
540 - move non
-Pidgin files to new sub
-package purple
-sipe
542 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
543 - remove directory
for emoticon theme icons
545 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
546 - libpurple protocol plugins are located under %
%{_libdir}/purple
-2
548 * Mon Sep
28 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
549 - added directory
for emoticon theme icons
551 * Wed Sep
09 2009 J. D. User
<jduser@noreply.com
> 1.6.3
554 * Fri Aug
28 2009 J. D. User
<jduser@noreply.com
> 1.6.2-*git
*
555 - reduce libpurple
-devel requirement to
>= 2.3.1
557 * Mon Aug
24 2009 J. D. User
<jduser@noreply.com
> 1.6.2
560 * Fri Aug
21 2009 J. D. User
<jduser@noreply.com
> 1.6.1-*git
*
561 - reduce libpurple
-devel requirement to
>= 2.4.1
563 * Mon Aug
17 2009 J. D. User
<jduser@noreply.com
> 1.6.1-*git
*
564 - com_err.h only required
for kerberos
566 * Tue Aug
11 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
567 - require libpurple
-devel
>= 2.5.0
569 * Sun Aug
09 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
570 - refactor configure parameters
571 - make kerberos configurable
572 - don't hard code prefix
for git builds
574 * Sun Aug
09 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
575 - removed unnecessary zlib
-devel
577 * Sat Aug
08 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
578 - fix prefix
for git builds
580 * Sat Aug
01 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
581 - append
-Wno
-unused
-parameter
for GCC
<4.4 compilation errors
583 * Thu Jul
30 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
584 - remove duplicate GPL2
586 * Thu Jul
30 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
587 - use "
--with git" to build from git
588 - corrected download
URL for release archive
589 - add missing BR gettext
-devel
591 * Wed Jul
29 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
592 - use default rpmbuild CFLAGS also
for git builds
593 - merge with SPEC files created by mricon
& jberanek
595 * Tue Jul
28 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
596 - initial RPM SPEC example generated