libwine: Remove __wine_main_arg* from the public header.
[wine/zf.git] / dlls / crtdll / crtdll.spec
blob9c88c2ac5ac2bfafb6d3ff9ce0e3b1ae8705799c
1 # Old C runtime library. All functions provided by msvcrt
3 @ cdecl -arch=win32 ??2@YAPAXI@Z(long) MSVCRT_operator_new
4 @ cdecl -arch=win64 ??2@YAPEAX_K@Z(long) MSVCRT_operator_new
5 @ cdecl -arch=win32 ??3@YAXPAX@Z(ptr) MSVCRT_operator_delete
6 @ cdecl -arch=win64 ??3@YAXPEAX@Z(ptr) MSVCRT_operator_delete
7 @ cdecl -arch=win32 ?_set_new_handler@@YAP6AHI@ZP6AHI@Z@Z(ptr) MSVCRT__set_new_handler
8 @ cdecl -arch=win64 ?_set_new_handler@@YAP6AH_K@ZP6AH0@Z@Z(ptr) MSVCRT__set_new_handler
9 @ cdecl -arch=i386 _CIacos()
10 @ cdecl -arch=i386 _CIasin()
11 @ cdecl -arch=i386 _CIatan()
12 @ cdecl -arch=i386 _CIatan2()
13 @ cdecl -arch=i386 _CIcos()
14 @ cdecl -arch=i386 _CIcosh()
15 @ cdecl -arch=i386 _CIexp()
16 @ cdecl -arch=i386 _CIfmod()
17 @ cdecl -arch=i386 _CIlog()
18 @ cdecl -arch=i386 _CIlog10()
19 @ cdecl -arch=i386 _CIpow()
20 @ cdecl -arch=i386 _CIsin()
21 @ cdecl -arch=i386 _CIsinh()
22 @ cdecl -arch=i386 _CIsqrt()
23 @ cdecl -arch=i386 _CItan()
24 @ cdecl -arch=i386 _CItanh()
25 @ extern _HUGE_dll MSVCRT__HUGE
26 @ cdecl _XcptFilter(long ptr)
27 @ cdecl __GetMainArgs(ptr ptr ptr long)
28 @ extern __argc_dll MSVCRT___argc
29 @ extern __argv_dll MSVCRT___argv
30 @ cdecl __dllonexit(ptr ptr ptr)
31 @ cdecl __doserrno() MSVCRT___doserrno
32 @ cdecl __fpecode()
33 @ cdecl __isascii(long) MSVCRT___isascii
34 @ cdecl __iscsym(long) MSVCRT___iscsym
35 @ cdecl __iscsymf(long) MSVCRT___iscsymf
36 @ extern __mb_cur_max_dll MSVCRT___mb_cur_max
37 @ cdecl __pxcptinfoptrs() MSVCRT___pxcptinfoptrs
38 @ cdecl __threadhandle() kernel32.GetCurrentThread
39 @ cdecl __threadid() kernel32.GetCurrentThreadId
40 @ cdecl __toascii(long) MSVCRT___toascii
41 @ cdecl _abnormal_termination()
42 @ cdecl _access(str long) MSVCRT__access
43 @ extern _acmdln_dll MSVCRT__acmdln
44 @ extern _aexit_rtn_dll _aexit_rtn
45 @ cdecl _amsg_exit(long)
46 @ cdecl _assert(str str long) MSVCRT__assert
47 @ extern _basemajor_dll CRTDLL__basemajor_dll
48 @ extern _baseminor_dll CRTDLL__baseminor_dll
49 @ extern _baseversion_dll MSVCRT__osver
50 @ cdecl _beep(long long) MSVCRT__beep
51 @ cdecl _beginthread(ptr long ptr)
52 @ cdecl _c_exit() MSVCRT__c_exit
53 @ cdecl _cabs(long) MSVCRT__cabs
54 @ cdecl _cexit() MSVCRT__cexit
55 @ cdecl _cgets(ptr)
56 @ cdecl _chdir(str) MSVCRT__chdir
57 @ cdecl _chdrive(long) MSVCRT__chdrive
58 @ cdecl _chgsign(double) MSVCRT__chgsign
59 @ cdecl _chmod(str long) MSVCRT__chmod
60 @ cdecl _chsize(long long) MSVCRT__chsize
61 @ cdecl _clearfp()
62 @ cdecl _close(long) MSVCRT__close
63 @ cdecl _commit(long) MSVCRT__commit
64 @ extern _commode_dll MSVCRT__commode
65 @ cdecl _control87(long long)
66 @ cdecl _controlfp(long long)
67 @ cdecl _copysign(double double) MSVCRT__copysign
68 @ varargs _cprintf(str)
69 @ extern _cpumode_dll CRTDLL__cpumode_dll
70 @ cdecl _cputs(str)
71 @ cdecl _creat(str long) MSVCRT__creat
72 @ varargs _cscanf(str)
73 @ extern _ctype MSVCRT__ctype
74 @ cdecl _cwait(ptr long long)
75 @ extern _daylight_dll MSVCRT___daylight
76 @ cdecl _dup(long) MSVCRT__dup
77 @ cdecl _dup2(long long) MSVCRT__dup2
78 @ cdecl _ecvt(double long ptr ptr) MSVCRT__ecvt
79 @ cdecl _endthread()
80 @ extern _environ_dll MSVCRT__environ
81 @ cdecl _eof(long) MSVCRT__eof
82 @ cdecl _errno() MSVCRT__errno
83 @ cdecl -arch=i386 _except_handler2(ptr ptr ptr ptr)
84 @ varargs _execl(str str)
85 @ varargs _execle(str str)
86 @ varargs _execlp(str str)
87 @ varargs _execlpe(str str)
88 @ cdecl _execv(str ptr)
89 @ cdecl _execve(str ptr ptr) MSVCRT__execve
90 @ cdecl _execvp(str ptr)
91 @ cdecl _execvpe(str ptr ptr)
92 @ cdecl _exit(long) MSVCRT__exit
93 @ cdecl _expand(ptr long)
94 @ cdecl _fcloseall() MSVCRT__fcloseall
95 @ cdecl _fcvt(double long ptr ptr) MSVCRT__fcvt
96 @ cdecl _fdopen(long str) MSVCRT__fdopen
97 @ cdecl _fgetchar() MSVCRT__fgetchar
98 @ cdecl _fgetwchar() MSVCRT__fgetwchar
99 @ cdecl _filbuf(ptr) MSVCRT__filbuf
100 # extern _fileinfo_dll
101 @ cdecl _filelength(long) MSVCRT__filelength
102 @ cdecl _fileno(ptr) MSVCRT__fileno
103 @ cdecl _findclose(long) MSVCRT__findclose
104 @ cdecl _findfirst(str ptr) MSVCRT__findfirst
105 @ cdecl _findnext(long ptr) MSVCRT__findnext
106 @ cdecl _finite(double) MSVCRT__finite
107 @ cdecl _flsbuf(long ptr) MSVCRT__flsbuf
108 @ cdecl _flushall() MSVCRT__flushall
109 @ extern _fmode_dll MSVCRT__fmode
110 @ cdecl _fpclass(double) MSVCRT__fpclass
111 @ cdecl -arch=i386,x86_64,arm,arm64 _fpieee_flt(long ptr ptr)
112 @ cdecl _fpreset()
113 @ cdecl _fputchar(long) MSVCRT__fputchar
114 @ cdecl _fputwchar(long) MSVCRT__fputwchar
115 @ cdecl _fsopen(str str long) MSVCRT__fsopen
116 @ cdecl _fstat(long ptr) MSVCRT__fstat
117 @ cdecl _ftime(ptr) MSVCRT__ftime
118 @ cdecl -arch=i386 -ret64 _ftol() MSVCRT__ftol
119 @ cdecl _fullpath(ptr str long) MSVCRT__fullpath
120 @ cdecl _futime(long ptr)
121 @ cdecl _gcvt(double long str) MSVCRT__gcvt
122 @ cdecl _get_osfhandle(long) MSVCRT__get_osfhandle
123 @ cdecl _getch()
124 @ cdecl _getche()
125 @ cdecl _getcwd(str long) MSVCRT__getcwd
126 @ cdecl _getdcwd(long str long) MSVCRT__getdcwd
127 @ cdecl _getdiskfree(long ptr) MSVCRT__getdiskfree
128 @ cdecl _getdllprocaddr(long str long)
129 @ cdecl _getdrive() MSVCRT__getdrive
130 @ cdecl _getdrives() kernel32.GetLogicalDrives
131 @ cdecl _getpid()
132 @ stub _getsystime(ptr)
133 @ cdecl _getw(ptr) MSVCRT__getw
134 @ cdecl -arch=i386 _global_unwind2(ptr)
135 @ cdecl _heapchk()
136 @ cdecl _heapmin()
137 @ cdecl _heapset(long)
138 @ cdecl _heapwalk(ptr)
139 @ cdecl _hypot(double double)
140 @ cdecl _initterm(ptr ptr)
141 @ extern _iob MSVCRT__iob
142 @ cdecl _isatty(long) MSVCRT__isatty
143 @ cdecl _isctype(long long) MSVCRT__isctype
144 @ stub _ismbbalnum(long)
145 @ stub _ismbbalpha(long)
146 @ stub _ismbbgraph(long)
147 @ stub _ismbbkalnum(long)
148 @ cdecl _ismbbkana(long)
149 @ stub _ismbbkpunct(long)
150 @ cdecl _ismbblead(long)
151 @ stub _ismbbprint(long)
152 @ stub _ismbbpunct(long)
153 @ cdecl _ismbbtrail(long)
154 @ cdecl _ismbcalpha(long)
155 @ cdecl _ismbcdigit(long)
156 @ cdecl _ismbchira(long)
157 @ cdecl _ismbckata(long)
158 @ cdecl _ismbcl0(long)
159 @ cdecl _ismbcl1(long)
160 @ cdecl _ismbcl2(long)
161 @ cdecl _ismbclegal(long)
162 @ cdecl _ismbclower(long)
163 @ cdecl _ismbcprint(long)
164 @ cdecl _ismbcspace(long)
165 @ cdecl _ismbcsymbol(long)
166 @ cdecl _ismbcupper(long)
167 @ cdecl _ismbslead(ptr ptr)
168 @ cdecl _ismbstrail(ptr ptr)
169 @ cdecl _isnan(double) MSVCRT__isnan
170 @ cdecl _itoa(long ptr long) MSVCRT__itoa
171 @ cdecl _itow(long ptr long) ntdll._itow
172 @ cdecl _j0(double) MSVCRT__j0
173 @ cdecl _j1(double) MSVCRT__j1
174 @ cdecl _jn(long double) MSVCRT__jn
175 @ cdecl _kbhit()
176 @ cdecl _lfind(ptr ptr ptr long ptr)
177 @ cdecl _loaddll(str)
178 @ cdecl -arch=i386 _local_unwind2(ptr long)
179 @ cdecl _locking(long long long) MSVCRT__locking
180 @ cdecl _logb(double) MSVCRT__logb
181 @ cdecl _lrotl(long long) MSVCRT__lrotl
182 @ cdecl _lrotr(long long) MSVCRT__lrotr
183 @ cdecl _lsearch(ptr ptr ptr long ptr)
184 @ cdecl _lseek(long long long) MSVCRT__lseek
185 @ cdecl _ltoa(long ptr long) ntdll._ltoa
186 @ cdecl _ltow(long ptr long) ntdll._ltow
187 @ cdecl _makepath(ptr str str str str) MSVCRT__makepath
188 @ cdecl _matherr(ptr) MSVCRT__matherr
189 @ cdecl _mbbtombc(long)
190 @ cdecl _mbbtype(long long)
191 @ cdecl _mbccpy(ptr ptr)
192 @ cdecl _mbcjistojms(long)
193 @ cdecl _mbcjmstojis(long)
194 @ cdecl _mbclen(ptr)
195 @ cdecl _mbctohira(long)
196 @ cdecl _mbctokata(long)
197 @ cdecl _mbctolower(long)
198 @ cdecl _mbctombb(long)
199 @ cdecl _mbctoupper(long)
200 @ extern _mbctype MSVCRT_mbctype
201 @ cdecl _mbsbtype(str long)
202 @ cdecl _mbscat(str str)
203 @ cdecl _mbschr(str long)
204 @ cdecl _mbscmp(str str)
205 @ cdecl _mbscpy(ptr str)
206 @ cdecl _mbscspn(str str)
207 @ cdecl _mbsdec(ptr ptr)
208 @ cdecl _mbsdup(str) MSVCRT__strdup
209 @ cdecl _mbsicmp(str str)
210 @ cdecl _mbsinc(str)
211 @ cdecl _mbslen(str)
212 @ cdecl _mbslwr(str)
213 @ cdecl _mbsnbcat(str str long)
214 @ cdecl _mbsnbcmp(str str long)
215 @ cdecl _mbsnbcnt(ptr long)
216 @ cdecl _mbsnbcpy(ptr str long)
217 @ cdecl _mbsnbicmp(str str long)
218 @ cdecl _mbsnbset(ptr long long)
219 @ cdecl _mbsncat(str str long)
220 @ cdecl _mbsnccnt(str long)
221 @ cdecl _mbsncmp(str str long)
222 @ cdecl _mbsncpy(ptr str long)
223 @ cdecl _mbsnextc(str)
224 @ cdecl _mbsnicmp(str str long)
225 @ cdecl _mbsninc(str long)
226 @ cdecl _mbsnset(ptr long long)
227 @ cdecl _mbspbrk(str str)
228 @ cdecl _mbsrchr(str long)
229 @ cdecl _mbsrev(str)
230 @ cdecl _mbsset(ptr long)
231 @ cdecl _mbsspn(str str)
232 @ cdecl _mbsspnp(str str)
233 @ cdecl _mbsstr(str str)
234 @ cdecl _mbstok(str str)
235 @ cdecl _mbstrlen(str)
236 @ cdecl _mbsupr(str)
237 @ cdecl _memccpy(ptr ptr long long) ntdll._memccpy
238 @ cdecl _memicmp(str str long) MSVCRT__memicmp
239 @ cdecl _mkdir(str) MSVCRT__mkdir
240 @ cdecl _mktemp(str) MSVCRT__mktemp
241 @ cdecl _msize(ptr)
242 @ cdecl _nextafter(double double) MSVCRT__nextafter
243 @ cdecl _onexit(ptr) MSVCRT__onexit
244 @ varargs _open(str long) MSVCRT__open
245 @ cdecl _open_osfhandle(long long) MSVCRT__open_osfhandle
246 @ extern _osmajor_dll MSVCRT__winmajor
247 @ extern _osminor_dll MSVCRT__winminor
248 @ extern _osmode_dll CRTDLL__osmode_dll
249 @ extern _osver_dll MSVCRT__osver
250 @ extern _osversion_dll MSVCRT__winver
251 @ cdecl _pclose(ptr) MSVCRT__pclose
252 @ extern _pctype_dll MSVCRT__pctype
253 @ extern _pgmptr_dll MSVCRT__pgmptr
254 @ cdecl _pipe(ptr long long) MSVCRT__pipe
255 @ cdecl _popen(str str) MSVCRT__popen
256 @ cdecl _purecall()
257 @ cdecl _putch(long)
258 @ cdecl _putenv(str)
259 @ cdecl _putw(long ptr) MSVCRT__putw
260 # extern _pwctype_dll
261 @ cdecl _read(long ptr long) MSVCRT__read
262 @ cdecl _rmdir(str) MSVCRT__rmdir
263 @ cdecl _rmtmp() MSVCRT__rmtmp
264 @ cdecl _rotl(long long)
265 @ cdecl _rotr(long long)
266 @ cdecl _scalb(double long) MSVCRT__scalb
267 @ cdecl _searchenv(str str ptr) MSVCRT__searchenv
268 @ cdecl _seterrormode(long)
269 @ cdecl -arch=i386,x86_64,arm,arm64 -norelay _setjmp(ptr) MSVCRT__setjmp
270 @ cdecl _setmode(long long) MSVCRT__setmode
271 @ stub _setsystime(ptr long)
272 @ cdecl _sleep(long) MSVCRT__sleep
273 @ varargs _snprintf(ptr long str) MSVCRT__snprintf
274 @ varargs _snwprintf(ptr long wstr) MSVCRT__snwprintf
275 @ varargs _sopen(str long long) MSVCRT__sopen
276 @ varargs _spawnl(long str str) MSVCRT__spawnl
277 @ varargs _spawnle(long str str) MSVCRT__spawnle
278 @ varargs _spawnlp(long str str) MSVCRT__spawnlp
279 @ varargs _spawnlpe(long str str) MSVCRT__spawnlpe
280 @ cdecl _spawnv(long str ptr) MSVCRT__spawnv
281 @ cdecl _spawnve(long str ptr ptr) MSVCRT__spawnve
282 @ cdecl _spawnvp(long str ptr) MSVCRT__spawnvp
283 @ cdecl _spawnvpe(long str ptr ptr) MSVCRT__spawnvpe
284 @ cdecl _splitpath(str ptr ptr ptr ptr) MSVCRT__splitpath
285 @ cdecl _stat(str ptr) MSVCRT_stat
286 @ cdecl _statusfp()
287 @ cdecl _strcmpi(str str) MSVCRT__stricmp
288 @ cdecl _strdate(ptr) MSVCRT__strdate
289 @ cdecl _strdec(str str)
290 @ cdecl _strdup(str) MSVCRT__strdup
291 @ cdecl _strerror(long) MSVCRT__strerror
292 @ cdecl _stricmp(str str) MSVCRT__stricmp
293 @ cdecl _stricoll(str str) MSVCRT__stricoll
294 @ cdecl _strinc(str)
295 @ cdecl _strlwr(str) MSVCRT__strlwr
296 @ cdecl _strncnt(str long) MSVCRT___strncnt
297 @ cdecl _strnextc(str)
298 @ cdecl _strnicmp(str str long) MSVCRT__strnicmp
299 @ cdecl _strninc(str long)
300 @ cdecl _strnset(str long long) MSVCRT__strnset
301 @ cdecl _strrev(str) MSVCRT__strrev
302 @ cdecl _strset(str long)
303 @ cdecl _strspnp(str str)
304 @ cdecl _strtime(ptr) MSVCRT__strtime
305 @ cdecl _strupr(str) MSVCRT__strupr
306 @ cdecl _swab(str str long) MSVCRT__swab
307 @ extern _sys_errlist MSVCRT__sys_errlist
308 @ extern _sys_nerr_dll MSVCRT__sys_nerr
309 @ cdecl _tell(long) MSVCRT__tell
310 @ cdecl _tempnam(str str) MSVCRT__tempnam
311 @ extern _timezone_dll MSVCRT___timezone
312 @ cdecl _tolower(long) MSVCRT__tolower
313 @ cdecl _toupper(long) MSVCRT__toupper
314 @ extern _tzname MSVCRT__tzname
315 @ cdecl _tzset() MSVCRT__tzset
316 @ cdecl _ultoa(long ptr long) ntdll._ultoa
317 @ cdecl _umask(long) MSVCRT__umask
318 @ cdecl _ungetch(long)
319 @ cdecl _unlink(str) MSVCRT__unlink
320 @ cdecl _unloaddll(long)
321 @ cdecl _utime(str ptr)
322 @ cdecl _vsnprintf(ptr long str ptr) MSVCRT_vsnprintf
323 @ cdecl _vsnwprintf(ptr long wstr ptr) MSVCRT_vsnwprintf
324 @ cdecl _wcsdup(wstr) MSVCRT__wcsdup
325 @ cdecl _wcsicmp(wstr wstr) MSVCRT__wcsicmp
326 @ cdecl _wcsicoll(wstr wstr) MSVCRT__wcsicoll
327 @ cdecl _wcslwr(wstr) MSVCRT__wcslwr
328 @ cdecl _wcsnicmp(wstr wstr long) MSVCRT__wcsnicmp
329 @ cdecl _wcsnset(wstr long long) MSVCRT__wcsnset
330 @ cdecl _wcsrev(wstr) MSVCRT__wcsrev
331 @ cdecl _wcsset(wstr long) MSVCRT__wcsset
332 @ cdecl _wcsupr(wstr) MSVCRT__wcsupr
333 @ extern _winmajor_dll MSVCRT__winmajor
334 @ extern _winminor_dll MSVCRT__winminor
335 @ extern _winver_dll MSVCRT__winver
336 @ cdecl _write(long ptr long) MSVCRT__write
337 @ cdecl _wtoi(wstr) MSVCRT__wtoi
338 @ cdecl _wtol(wstr) MSVCRT__wtol
339 @ cdecl _y0(double) MSVCRT__y0
340 @ cdecl _y1(double) MSVCRT__y1
341 @ cdecl _yn(long double) MSVCRT__yn
342 @ cdecl abort() MSVCRT_abort
343 @ cdecl abs(long) MSVCRT_abs
344 @ cdecl acos(double) MSVCRT_acos
345 @ cdecl asctime(ptr) MSVCRT_asctime
346 @ cdecl asin(double) MSVCRT_asin
347 @ cdecl atan(double) MSVCRT_atan
348 @ cdecl atan2(double double) MSVCRT_atan2
349 @ cdecl -private atexit(ptr) MSVCRT_atexit
350 @ cdecl atof(str) MSVCRT_atof
351 @ cdecl atoi(str) MSVCRT_atoi
352 @ cdecl atol(str) MSVCRT_atol
353 @ cdecl bsearch(ptr ptr long long ptr) MSVCRT_bsearch
354 @ cdecl calloc(long long) MSVCRT_calloc
355 @ cdecl ceil(double) MSVCRT_ceil
356 @ cdecl clearerr(ptr) MSVCRT_clearerr
357 @ cdecl clock() MSVCRT_clock
358 @ cdecl cos(double) MSVCRT_cos
359 @ cdecl cosh(double) MSVCRT_cosh
360 @ cdecl ctime(ptr) MSVCRT_ctime
361 @ cdecl difftime(long long) MSVCRT_difftime
362 @ cdecl -ret64 div(long long) MSVCRT_div
363 @ cdecl exit(long) MSVCRT_exit
364 @ cdecl exp(double) MSVCRT_exp
365 @ cdecl fabs(double) MSVCRT_fabs
366 @ cdecl fclose(ptr) MSVCRT_fclose
367 @ cdecl feof(ptr) MSVCRT_feof
368 @ cdecl ferror(ptr) MSVCRT_ferror
369 @ cdecl fflush(ptr) MSVCRT_fflush
370 @ cdecl fgetc(ptr) MSVCRT_fgetc
371 @ cdecl fgetpos(ptr ptr) MSVCRT_fgetpos
372 @ cdecl fgets(ptr long ptr) MSVCRT_fgets
373 @ cdecl fgetwc(ptr) MSVCRT_fgetwc
374 @ cdecl floor(double) MSVCRT_floor
375 @ cdecl fmod(double double) MSVCRT_fmod
376 @ cdecl fopen(str str) MSVCRT_fopen
377 @ varargs fprintf(ptr str) MSVCRT_fprintf
378 @ cdecl fputc(long ptr) MSVCRT_fputc
379 @ cdecl fputs(str ptr) MSVCRT_fputs
380 @ cdecl fputwc(long ptr) MSVCRT_fputwc
381 @ cdecl fread(ptr long long ptr) MSVCRT_fread
382 @ cdecl free(ptr) MSVCRT_free
383 @ cdecl freopen(str str ptr) MSVCRT_freopen
384 @ cdecl frexp(double ptr) MSVCRT_frexp
385 @ varargs fscanf(ptr str) MSVCRT_fscanf
386 @ cdecl fseek(ptr long long) MSVCRT_fseek
387 @ cdecl fsetpos(ptr ptr) MSVCRT_fsetpos
388 @ cdecl ftell(ptr) MSVCRT_ftell
389 @ varargs fwprintf(ptr wstr) MSVCRT_fwprintf
390 @ cdecl fwrite(ptr long long ptr) MSVCRT_fwrite
391 @ varargs fwscanf(ptr wstr) MSVCRT_fwscanf
392 @ cdecl getc(ptr) MSVCRT_getc
393 @ cdecl getchar() MSVCRT_getchar
394 @ cdecl getenv(str) MSVCRT_getenv
395 @ cdecl gets(str) MSVCRT_gets
396 @ cdecl gmtime(ptr) MSVCRT_gmtime
397 @ cdecl is_wctype(long long) MSVCRT_iswctype
398 @ cdecl isalnum(long) MSVCRT_isalnum
399 @ cdecl isalpha(long) MSVCRT_isalpha
400 @ cdecl iscntrl(long) MSVCRT_iscntrl
401 @ cdecl isdigit(long) MSVCRT_isdigit
402 @ cdecl isgraph(long) MSVCRT_isgraph
403 @ cdecl isleadbyte(long) MSVCRT_isleadbyte
404 @ cdecl islower(long) MSVCRT_islower
405 @ cdecl isprint(long) MSVCRT_isprint
406 @ cdecl ispunct(long) MSVCRT_ispunct
407 @ cdecl isspace(long) MSVCRT_isspace
408 @ cdecl isupper(long) MSVCRT_isupper
409 @ cdecl iswalnum(long) MSVCRT_iswalnum
410 @ cdecl iswalpha(long) MSVCRT_iswalpha
411 @ cdecl iswascii(long) MSVCRT_iswascii
412 @ cdecl iswcntrl(long) MSVCRT_iswcntrl
413 @ cdecl iswctype(long long) MSVCRT_iswctype
414 @ cdecl iswdigit(long) MSVCRT_iswdigit
415 @ cdecl iswgraph(long) MSVCRT_iswgraph
416 @ cdecl iswlower(long) MSVCRT_iswlower
417 @ cdecl iswprint(long) MSVCRT_iswprint
418 @ cdecl iswpunct(long) MSVCRT_iswpunct
419 @ cdecl iswspace(long) MSVCRT_iswspace
420 @ cdecl iswupper(long) MSVCRT_iswupper
421 @ cdecl iswxdigit(long) MSVCRT_iswxdigit
422 @ cdecl isxdigit(long) MSVCRT_isxdigit
423 @ cdecl labs(long) MSVCRT_labs
424 @ cdecl ldexp(double long) MSVCRT_ldexp
425 @ cdecl ldiv(long long) MSVCRT_ldiv
426 @ cdecl localeconv() MSVCRT_localeconv
427 @ cdecl localtime(ptr) MSVCRT_localtime
428 @ cdecl log(double) MSVCRT_log
429 @ cdecl log10(double) MSVCRT_log10
430 @ cdecl -arch=i386,x86_64,arm,arm64 longjmp(ptr long) MSVCRT_longjmp
431 @ cdecl malloc(long) MSVCRT_malloc
432 @ cdecl mblen(ptr long) MSVCRT_mblen
433 @ cdecl mbstowcs(ptr str long) MSVCRT_mbstowcs
434 @ cdecl mbtowc(ptr str long) MSVCRT_mbtowc
435 @ cdecl memchr(ptr long long) MSVCRT_memchr
436 @ cdecl memcmp(ptr ptr long) MSVCRT_memcmp
437 @ cdecl memcpy(ptr ptr long) MSVCRT_memcpy
438 @ cdecl memmove(ptr ptr long) MSVCRT_memmove
439 @ cdecl memset(ptr long long) MSVCRT_memset
440 @ cdecl mktime(ptr) MSVCRT_mktime
441 @ cdecl modf(double ptr) MSVCRT_modf
442 @ cdecl perror(str) MSVCRT_perror
443 @ cdecl pow(double double) MSVCRT_pow
444 @ varargs printf(str) MSVCRT_printf
445 @ cdecl putc(long ptr) MSVCRT_putc
446 @ cdecl putchar(long) MSVCRT_putchar
447 @ cdecl puts(str) MSVCRT_puts
448 @ cdecl qsort(ptr long long ptr) MSVCRT_qsort
449 @ cdecl raise(long) MSVCRT_raise
450 @ cdecl rand() MSVCRT_rand
451 @ cdecl realloc(ptr long) MSVCRT_realloc
452 @ cdecl remove(str) MSVCRT_remove
453 @ cdecl rename(str str) MSVCRT_rename
454 @ cdecl rewind(ptr) MSVCRT_rewind
455 @ varargs scanf(str) MSVCRT_scanf
456 @ cdecl setbuf(ptr ptr) MSVCRT_setbuf
457 @ cdecl setlocale(long str) MSVCRT_setlocale
458 @ cdecl setvbuf(ptr str long long) MSVCRT_setvbuf
459 @ cdecl signal(long long) MSVCRT_signal
460 @ cdecl sin(double) MSVCRT_sin
461 @ cdecl sinh(double) MSVCRT_sinh
462 @ varargs sprintf(ptr str) MSVCRT_sprintf
463 @ cdecl sqrt(double) MSVCRT_sqrt
464 @ cdecl srand(long) MSVCRT_srand
465 @ varargs sscanf(str str) MSVCRT_sscanf
466 @ cdecl strcat(str str) ntdll.strcat
467 @ cdecl strchr(str long) MSVCRT_strchr
468 @ cdecl strcmp(str str) MSVCRT_strcmp
469 @ cdecl strcoll(str str) MSVCRT_strcoll
470 @ cdecl strcpy(ptr str) MSVCRT_strcpy
471 @ cdecl strcspn(str str) MSVCRT_strcspn
472 @ cdecl strerror(long) MSVCRT_strerror
473 @ cdecl strftime(ptr long str ptr) MSVCRT_strftime
474 @ cdecl strlen(str) MSVCRT_strlen
475 @ cdecl strncat(str str long) MSVCRT_strncat
476 @ cdecl strncmp(str str long) MSVCRT_strncmp
477 @ cdecl strncpy(ptr str long) MSVCRT_strncpy
478 @ cdecl strpbrk(str str) MSVCRT_strpbrk
479 @ cdecl strrchr(str long) MSVCRT_strrchr
480 @ cdecl strspn(str str) ntdll.strspn
481 @ cdecl strstr(str str) MSVCRT_strstr
482 @ cdecl strtod(str ptr) MSVCRT_strtod
483 @ cdecl strtok(str str) MSVCRT_strtok
484 @ cdecl strtol(str ptr long) MSVCRT_strtol
485 @ cdecl strtoul(str ptr long) MSVCRT_strtoul
486 @ cdecl strxfrm(ptr str long) MSVCRT_strxfrm
487 @ varargs swprintf(ptr wstr) MSVCRT_swprintf
488 @ varargs swscanf(wstr wstr) MSVCRT_swscanf
489 @ cdecl system(str) MSVCRT_system
490 @ cdecl tan(double) MSVCRT_tan
491 @ cdecl tanh(double) MSVCRT_tanh
492 @ cdecl time(ptr) MSVCRT_time
493 @ cdecl tmpfile() MSVCRT_tmpfile
494 @ cdecl tmpnam(ptr) MSVCRT_tmpnam
495 @ cdecl tolower(long) MSVCRT_tolower
496 @ cdecl toupper(long) MSVCRT_toupper
497 @ cdecl towlower(long) MSVCRT_towlower
498 @ cdecl towupper(long) MSVCRT_towupper
499 @ cdecl ungetc(long ptr) MSVCRT_ungetc
500 @ cdecl ungetwc(long ptr) MSVCRT_ungetwc
501 @ cdecl vfprintf(ptr str ptr) MSVCRT_vfprintf
502 @ cdecl vfwprintf(ptr wstr ptr) MSVCRT_vfwprintf
503 @ cdecl vprintf(str ptr) MSVCRT_vprintf
504 @ cdecl vsprintf(ptr str ptr) MSVCRT_vsprintf
505 @ cdecl vswprintf(ptr wstr ptr) MSVCRT_vswprintf
506 @ cdecl vwprintf(wstr ptr) MSVCRT_vwprintf
507 @ cdecl wcscat(wstr wstr) ntdll.wcscat
508 @ cdecl wcschr(wstr long) MSVCRT_wcschr
509 @ cdecl wcscmp(wstr wstr) MSVCRT_wcscmp
510 @ cdecl wcscoll(wstr wstr) MSVCRT_wcscoll
511 @ cdecl wcscpy(ptr wstr) ntdll.wcscpy
512 @ cdecl wcscspn(wstr wstr) ntdll.wcscspn
513 @ cdecl wcsftime(ptr long wstr ptr) MSVCRT_wcsftime
514 @ cdecl wcslen(wstr) MSVCRT_wcslen
515 @ cdecl wcsncat(wstr wstr long) ntdll.wcsncat
516 @ cdecl wcsncmp(wstr wstr long) MSVCRT_wcsncmp
517 @ cdecl wcsncpy(ptr wstr long) MSVCRT_wcsncpy
518 @ cdecl wcspbrk(wstr wstr) MSVCRT_wcspbrk
519 @ cdecl wcsrchr(wstr long) MSVCRT_wcsrchr
520 @ cdecl wcsspn(wstr wstr) ntdll.wcsspn
521 @ cdecl wcsstr(wstr wstr) MSVCRT_wcsstr
522 @ cdecl wcstod(wstr ptr) MSVCRT_wcstod
523 @ cdecl wcstok(wstr wstr) MSVCRT_wcstok
524 @ cdecl wcstol(wstr ptr long) MSVCRT_wcstol
525 @ cdecl wcstombs(ptr ptr long) MSVCRT_wcstombs
526 @ cdecl wcstoul(wstr ptr long) MSVCRT_wcstoul
527 @ cdecl wcsxfrm(ptr wstr long) MSVCRT_wcsxfrm
528 @ cdecl wctomb(ptr long) MSVCRT_wctomb
529 @ varargs wprintf(wstr) MSVCRT_wprintf
530 @ varargs wscanf(wstr) MSVCRT_wscanf