1 # Automatically generated from Vulkan vk.xml; DO NOT EDIT!
3 # This file is generated from Vulkan vk.xml file covered
4 # by the following copyright and permission notice:
6 # Copyright (c) 2015-2020 The Khronos Group Inc.
8 # Licensed under the Apache License, Version 2.0 (the "License");
9 # you may not use this file except in compliance with the License.
10 # You may obtain a copy of the License at
12 # http://www.apache.org/licenses/LICENSE-2.0
14 # Unless required by applicable law or agreed to in writing, software
15 # distributed under the License is distributed on an "AS IS" BASIS,
16 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
17 # See the License for the specific language governing permissions and
18 # limitations under the License.
20 # ---- Exceptions to the Apache 2.0 License: ----
22 # As an exception, if you use this Software to generate code and portions of
23 # this Software are embedded into the generated code as a result, you may
24 # redistribute such product without providing attribution as would otherwise
25 # be required by Sections 4(a), 4(b) and 4(d) of the License.
27 # In addition, if you combine or link code generated by this Software with
28 # software that is licensed under the GPLv2 or the LGPL v2.0 or 2.1
29 # ("`Combined Software`") and if a court of competent jurisdiction determines
30 # that the patent provision (Section 3), the indemnity provision (Section 9)
31 # or other Section of the License conflicts with the conditions of the
32 # applicable GPL or LGPL license, you may retroactively and prospectively
33 # choose to deem waived or otherwise exclude such Section(s) of the License,
34 # but only in their entirety and only with respect to the Combined Software.
37 @ stdcall vkAcquireNextImage2KHR
(ptr ptr ptr
) winevulkan.wine_vkAcquireNextImage2KHR
38 @ stdcall vkAcquireNextImageKHR
(ptr int64 int64 int64 int64 ptr
) winevulkan.wine_vkAcquireNextImageKHR
39 @ stdcall vkAllocateCommandBuffers
(ptr ptr ptr
) winevulkan.wine_vkAllocateCommandBuffers
40 @ stdcall vkAllocateDescriptorSets
(ptr ptr ptr
) winevulkan.wine_vkAllocateDescriptorSets
41 @ stdcall vkAllocateMemory
(ptr ptr ptr ptr
) winevulkan.wine_vkAllocateMemory
42 @ stdcall vkBeginCommandBuffer
(ptr ptr
) winevulkan.wine_vkBeginCommandBuffer
43 @ stdcall vkBindBufferMemory
(ptr int64 int64 int64
) winevulkan.wine_vkBindBufferMemory
44 @ stdcall vkBindBufferMemory2
(ptr long ptr
) winevulkan.wine_vkBindBufferMemory2
45 @ stdcall vkBindImageMemory
(ptr int64 int64 int64
) winevulkan.wine_vkBindImageMemory
46 @ stdcall vkBindImageMemory2
(ptr long ptr
) winevulkan.wine_vkBindImageMemory2
47 @ stdcall vkCmdBeginQuery
(ptr int64 long long
) winevulkan.wine_vkCmdBeginQuery
48 @ stdcall vkCmdBeginRenderPass
(ptr ptr long
) winevulkan.wine_vkCmdBeginRenderPass
49 @ stdcall vkCmdBeginRenderPass2
(ptr ptr ptr
) winevulkan.wine_vkCmdBeginRenderPass2
50 @ stdcall vkCmdBindDescriptorSets
(ptr long int64 long long ptr long ptr
) winevulkan.wine_vkCmdBindDescriptorSets
51 @ stdcall vkCmdBindIndexBuffer
(ptr int64 int64 long
) winevulkan.wine_vkCmdBindIndexBuffer
52 @ stdcall vkCmdBindPipeline
(ptr long int64
) winevulkan.wine_vkCmdBindPipeline
53 @ stdcall vkCmdBindVertexBuffers
(ptr long long ptr ptr
) winevulkan.wine_vkCmdBindVertexBuffers
54 @ stdcall vkCmdBlitImage
(ptr int64 long int64 long long ptr long
) winevulkan.wine_vkCmdBlitImage
55 @ stdcall vkCmdClearAttachments
(ptr long ptr long ptr
) winevulkan.wine_vkCmdClearAttachments
56 @ stdcall vkCmdClearColorImage
(ptr int64 long ptr long ptr
) winevulkan.wine_vkCmdClearColorImage
57 @ stdcall vkCmdClearDepthStencilImage
(ptr int64 long ptr long ptr
) winevulkan.wine_vkCmdClearDepthStencilImage
58 @ stdcall vkCmdCopyBuffer
(ptr int64 int64 long ptr
) winevulkan.wine_vkCmdCopyBuffer
59 @ stdcall vkCmdCopyBufferToImage
(ptr int64 int64 long long ptr
) winevulkan.wine_vkCmdCopyBufferToImage
60 @ stdcall vkCmdCopyImage
(ptr int64 long int64 long long ptr
) winevulkan.wine_vkCmdCopyImage
61 @ stdcall vkCmdCopyImageToBuffer
(ptr int64 long int64 long ptr
) winevulkan.wine_vkCmdCopyImageToBuffer
62 @ stdcall vkCmdCopyQueryPoolResults
(ptr int64 long long int64 int64 int64 long
) winevulkan.wine_vkCmdCopyQueryPoolResults
63 @ stdcall vkCmdDispatch
(ptr long long long
) winevulkan.wine_vkCmdDispatch
64 @ stdcall vkCmdDispatchBase
(ptr long long long long long long
) winevulkan.wine_vkCmdDispatchBase
65 @ stdcall vkCmdDispatchIndirect
(ptr int64 int64
) winevulkan.wine_vkCmdDispatchIndirect
66 @ stdcall vkCmdDraw
(ptr long long long long
) winevulkan.wine_vkCmdDraw
67 @ stdcall vkCmdDrawIndexed
(ptr long long long long long
) winevulkan.wine_vkCmdDrawIndexed
68 @ stdcall vkCmdDrawIndexedIndirect
(ptr int64 int64 long long
) winevulkan.wine_vkCmdDrawIndexedIndirect
69 @ stdcall vkCmdDrawIndexedIndirectCount
(ptr int64 int64 int64 int64 long long
) winevulkan.wine_vkCmdDrawIndexedIndirectCount
70 @ stdcall vkCmdDrawIndirect
(ptr int64 int64 long long
) winevulkan.wine_vkCmdDrawIndirect
71 @ stdcall vkCmdDrawIndirectCount
(ptr int64 int64 int64 int64 long long
) winevulkan.wine_vkCmdDrawIndirectCount
72 @ stdcall vkCmdEndQuery
(ptr int64 long
) winevulkan.wine_vkCmdEndQuery
73 @ stdcall vkCmdEndRenderPass
(ptr
) winevulkan.wine_vkCmdEndRenderPass
74 @ stdcall vkCmdEndRenderPass2
(ptr ptr
) winevulkan.wine_vkCmdEndRenderPass2
75 @ stdcall vkCmdExecuteCommands
(ptr long ptr
) winevulkan.wine_vkCmdExecuteCommands
76 @ stdcall vkCmdFillBuffer
(ptr int64 int64 int64 long
) winevulkan.wine_vkCmdFillBuffer
77 @ stdcall vkCmdNextSubpass
(ptr long
) winevulkan.wine_vkCmdNextSubpass
78 @ stdcall vkCmdNextSubpass2
(ptr ptr ptr
) winevulkan.wine_vkCmdNextSubpass2
79 @ stdcall vkCmdPipelineBarrier
(ptr long long long long ptr long ptr long ptr
) winevulkan.wine_vkCmdPipelineBarrier
80 @ stdcall vkCmdPushConstants
(ptr int64 long long long ptr
) winevulkan.wine_vkCmdPushConstants
81 @ stdcall vkCmdResetEvent
(ptr int64 long
) winevulkan.wine_vkCmdResetEvent
82 @ stdcall vkCmdResetQueryPool
(ptr int64 long long
) winevulkan.wine_vkCmdResetQueryPool
83 @ stdcall vkCmdResolveImage
(ptr int64 long int64 long long ptr
) winevulkan.wine_vkCmdResolveImage
84 @ stdcall vkCmdSetBlendConstants
(ptr ptr
) winevulkan.wine_vkCmdSetBlendConstants
85 @ stdcall vkCmdSetDepthBias
(ptr float float float
) winevulkan.wine_vkCmdSetDepthBias
86 @ stdcall vkCmdSetDepthBounds
(ptr float float
) winevulkan.wine_vkCmdSetDepthBounds
87 @ stdcall vkCmdSetDeviceMask
(ptr long
) winevulkan.wine_vkCmdSetDeviceMask
88 @ stdcall vkCmdSetEvent
(ptr int64 long
) winevulkan.wine_vkCmdSetEvent
89 @ stdcall vkCmdSetLineWidth
(ptr float
) winevulkan.wine_vkCmdSetLineWidth
90 @ stdcall vkCmdSetScissor
(ptr long long ptr
) winevulkan.wine_vkCmdSetScissor
91 @ stdcall vkCmdSetStencilCompareMask
(ptr long long
) winevulkan.wine_vkCmdSetStencilCompareMask
92 @ stdcall vkCmdSetStencilReference
(ptr long long
) winevulkan.wine_vkCmdSetStencilReference
93 @ stdcall vkCmdSetStencilWriteMask
(ptr long long
) winevulkan.wine_vkCmdSetStencilWriteMask
94 @ stdcall vkCmdSetViewport
(ptr long long ptr
) winevulkan.wine_vkCmdSetViewport
95 @ stdcall vkCmdUpdateBuffer
(ptr int64 int64 int64 ptr
) winevulkan.wine_vkCmdUpdateBuffer
96 @ stdcall vkCmdWaitEvents
(ptr long ptr long long long ptr long ptr long ptr
) winevulkan.wine_vkCmdWaitEvents
97 @ stdcall vkCmdWriteTimestamp
(ptr long int64 long
) winevulkan.wine_vkCmdWriteTimestamp
98 @ stdcall vkCreateBuffer
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateBuffer
99 @ stdcall vkCreateBufferView
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateBufferView
100 @ stdcall vkCreateCommandPool
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateCommandPool
101 @ stdcall vkCreateComputePipelines
(ptr int64 long ptr ptr ptr
) winevulkan.wine_vkCreateComputePipelines
102 @ stdcall vkCreateDescriptorPool
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateDescriptorPool
103 @ stdcall vkCreateDescriptorSetLayout
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateDescriptorSetLayout
104 @ stdcall vkCreateDescriptorUpdateTemplate
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateDescriptorUpdateTemplate
105 @ stdcall vkCreateDevice
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateDevice
106 @ stub vkCreateDisplayModeKHR
107 @ stub vkCreateDisplayPlaneSurfaceKHR
108 @ stdcall vkCreateEvent
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateEvent
109 @ stdcall vkCreateFence
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateFence
110 @ stdcall vkCreateFramebuffer
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateFramebuffer
111 @ stdcall vkCreateGraphicsPipelines
(ptr int64 long ptr ptr ptr
) winevulkan.wine_vkCreateGraphicsPipelines
112 @ stdcall vkCreateImage
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateImage
113 @ stdcall vkCreateImageView
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateImageView
114 @ stdcall vkCreateInstance
(ptr ptr ptr
) winevulkan.wine_vkCreateInstance
115 @ stdcall vkCreatePipelineCache
(ptr ptr ptr ptr
) winevulkan.wine_vkCreatePipelineCache
116 @ stdcall vkCreatePipelineLayout
(ptr ptr ptr ptr
) winevulkan.wine_vkCreatePipelineLayout
117 @ stdcall vkCreateQueryPool
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateQueryPool
118 @ stdcall vkCreateRenderPass
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateRenderPass
119 @ stdcall vkCreateRenderPass2
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateRenderPass2
120 @ stdcall vkCreateSampler
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateSampler
121 @ stdcall vkCreateSamplerYcbcrConversion
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateSamplerYcbcrConversion
122 @ stdcall vkCreateSemaphore
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateSemaphore
123 @ stdcall vkCreateShaderModule
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateShaderModule
124 @ stub vkCreateSharedSwapchainsKHR
125 @ stdcall vkCreateSwapchainKHR
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateSwapchainKHR
126 @ stdcall vkCreateWin32SurfaceKHR
(ptr ptr ptr ptr
) winevulkan.wine_vkCreateWin32SurfaceKHR
127 @ stdcall vkDestroyBuffer
(ptr int64 ptr
) winevulkan.wine_vkDestroyBuffer
128 @ stdcall vkDestroyBufferView
(ptr int64 ptr
) winevulkan.wine_vkDestroyBufferView
129 @ stdcall vkDestroyCommandPool
(ptr int64 ptr
) winevulkan.wine_vkDestroyCommandPool
130 @ stdcall vkDestroyDescriptorPool
(ptr int64 ptr
) winevulkan.wine_vkDestroyDescriptorPool
131 @ stdcall vkDestroyDescriptorSetLayout
(ptr int64 ptr
) winevulkan.wine_vkDestroyDescriptorSetLayout
132 @ stdcall vkDestroyDescriptorUpdateTemplate
(ptr int64 ptr
) winevulkan.wine_vkDestroyDescriptorUpdateTemplate
133 @ stdcall vkDestroyDevice
(ptr ptr
) winevulkan.wine_vkDestroyDevice
134 @ stdcall vkDestroyEvent
(ptr int64 ptr
) winevulkan.wine_vkDestroyEvent
135 @ stdcall vkDestroyFence
(ptr int64 ptr
) winevulkan.wine_vkDestroyFence
136 @ stdcall vkDestroyFramebuffer
(ptr int64 ptr
) winevulkan.wine_vkDestroyFramebuffer
137 @ stdcall vkDestroyImage
(ptr int64 ptr
) winevulkan.wine_vkDestroyImage
138 @ stdcall vkDestroyImageView
(ptr int64 ptr
) winevulkan.wine_vkDestroyImageView
139 @ stdcall vkDestroyInstance
(ptr ptr
) winevulkan.wine_vkDestroyInstance
140 @ stdcall vkDestroyPipeline
(ptr int64 ptr
) winevulkan.wine_vkDestroyPipeline
141 @ stdcall vkDestroyPipelineCache
(ptr int64 ptr
) winevulkan.wine_vkDestroyPipelineCache
142 @ stdcall vkDestroyPipelineLayout
(ptr int64 ptr
) winevulkan.wine_vkDestroyPipelineLayout
143 @ stdcall vkDestroyQueryPool
(ptr int64 ptr
) winevulkan.wine_vkDestroyQueryPool
144 @ stdcall vkDestroyRenderPass
(ptr int64 ptr
) winevulkan.wine_vkDestroyRenderPass
145 @ stdcall vkDestroySampler
(ptr int64 ptr
) winevulkan.wine_vkDestroySampler
146 @ stdcall vkDestroySamplerYcbcrConversion
(ptr int64 ptr
) winevulkan.wine_vkDestroySamplerYcbcrConversion
147 @ stdcall vkDestroySemaphore
(ptr int64 ptr
) winevulkan.wine_vkDestroySemaphore
148 @ stdcall vkDestroyShaderModule
(ptr int64 ptr
) winevulkan.wine_vkDestroyShaderModule
149 @ stdcall vkDestroySurfaceKHR
(ptr int64 ptr
) winevulkan.wine_vkDestroySurfaceKHR
150 @ stdcall vkDestroySwapchainKHR
(ptr int64 ptr
) winevulkan.wine_vkDestroySwapchainKHR
151 @ stdcall vkDeviceWaitIdle
(ptr
) winevulkan.wine_vkDeviceWaitIdle
152 @ stdcall vkEndCommandBuffer
(ptr
) winevulkan.wine_vkEndCommandBuffer
153 @ stdcall vkEnumerateDeviceExtensionProperties
(ptr str ptr ptr
) winevulkan.wine_vkEnumerateDeviceExtensionProperties
154 @ stdcall vkEnumerateDeviceLayerProperties
(ptr ptr ptr
) winevulkan.wine_vkEnumerateDeviceLayerProperties
155 @ stdcall vkEnumerateInstanceExtensionProperties
(str ptr ptr
) winevulkan.wine_vkEnumerateInstanceExtensionProperties
156 @ stdcall vkEnumerateInstanceLayerProperties
(ptr ptr
) winevulkan.wine_vkEnumerateInstanceLayerProperties
157 @ stdcall vkEnumerateInstanceVersion
(ptr
) winevulkan.wine_vkEnumerateInstanceVersion
158 @ stdcall vkEnumeratePhysicalDeviceGroups
(ptr ptr ptr
) winevulkan.wine_vkEnumeratePhysicalDeviceGroups
159 @ stdcall vkEnumeratePhysicalDevices
(ptr ptr ptr
) winevulkan.wine_vkEnumeratePhysicalDevices
160 @ stdcall vkFlushMappedMemoryRanges
(ptr long ptr
) winevulkan.wine_vkFlushMappedMemoryRanges
161 @ stdcall vkFreeCommandBuffers
(ptr int64 long ptr
) winevulkan.wine_vkFreeCommandBuffers
162 @ stdcall vkFreeDescriptorSets
(ptr int64 long ptr
) winevulkan.wine_vkFreeDescriptorSets
163 @ stdcall vkFreeMemory
(ptr int64 ptr
) winevulkan.wine_vkFreeMemory
164 @ stdcall vkGetBufferDeviceAddress
(ptr ptr
) winevulkan.wine_vkGetBufferDeviceAddress
165 @ stdcall vkGetBufferMemoryRequirements
(ptr int64 ptr
) winevulkan.wine_vkGetBufferMemoryRequirements
166 @ stdcall vkGetBufferMemoryRequirements2
(ptr ptr ptr
) winevulkan.wine_vkGetBufferMemoryRequirements2
167 @ stdcall vkGetBufferOpaqueCaptureAddress
(ptr ptr
) winevulkan.wine_vkGetBufferOpaqueCaptureAddress
168 @ stdcall vkGetDescriptorSetLayoutSupport
(ptr ptr ptr
) winevulkan.wine_vkGetDescriptorSetLayoutSupport
169 @ stdcall vkGetDeviceGroupPeerMemoryFeatures
(ptr long long long ptr
) winevulkan.wine_vkGetDeviceGroupPeerMemoryFeatures
170 @ stdcall vkGetDeviceGroupPresentCapabilitiesKHR
(ptr ptr
) winevulkan.wine_vkGetDeviceGroupPresentCapabilitiesKHR
171 @ stdcall vkGetDeviceGroupSurfacePresentModesKHR
(ptr int64 ptr
) winevulkan.wine_vkGetDeviceGroupSurfacePresentModesKHR
172 @ stdcall vkGetDeviceMemoryCommitment
(ptr int64 ptr
) winevulkan.wine_vkGetDeviceMemoryCommitment
173 @ stdcall vkGetDeviceMemoryOpaqueCaptureAddress
(ptr ptr
) winevulkan.wine_vkGetDeviceMemoryOpaqueCaptureAddress
174 @ stdcall vkGetDeviceProcAddr
(ptr str
) winevulkan.wine_vkGetDeviceProcAddr
175 @ stdcall vkGetDeviceQueue
(ptr long long ptr
) winevulkan.wine_vkGetDeviceQueue
176 @ stdcall vkGetDeviceQueue2
(ptr ptr ptr
) winevulkan.wine_vkGetDeviceQueue2
177 @ stub vkGetDisplayModePropertiesKHR
178 @ stub vkGetDisplayPlaneCapabilitiesKHR
179 @ stub vkGetDisplayPlaneSupportedDisplaysKHR
180 @ stdcall vkGetEventStatus
(ptr int64
) winevulkan.wine_vkGetEventStatus
181 @ stdcall vkGetFenceStatus
(ptr int64
) winevulkan.wine_vkGetFenceStatus
182 @ stdcall vkGetImageMemoryRequirements
(ptr int64 ptr
) winevulkan.wine_vkGetImageMemoryRequirements
183 @ stdcall vkGetImageMemoryRequirements2
(ptr ptr ptr
) winevulkan.wine_vkGetImageMemoryRequirements2
184 @ stdcall vkGetImageSparseMemoryRequirements
(ptr int64 ptr ptr
) winevulkan.wine_vkGetImageSparseMemoryRequirements
185 @ stdcall vkGetImageSparseMemoryRequirements2
(ptr ptr ptr ptr
) winevulkan.wine_vkGetImageSparseMemoryRequirements2
186 @ stdcall vkGetImageSubresourceLayout
(ptr int64 ptr ptr
) winevulkan.wine_vkGetImageSubresourceLayout
187 @ stdcall vkGetInstanceProcAddr
(ptr str
) winevulkan.wine_vkGetInstanceProcAddr
188 @ stub vkGetPhysicalDeviceDisplayPlanePropertiesKHR
189 @ stub vkGetPhysicalDeviceDisplayPropertiesKHR
190 @ stdcall vkGetPhysicalDeviceExternalBufferProperties
(ptr ptr ptr
) winevulkan.wine_vkGetPhysicalDeviceExternalBufferProperties
191 @ stdcall vkGetPhysicalDeviceExternalFenceProperties
(ptr ptr ptr
) winevulkan.wine_vkGetPhysicalDeviceExternalFenceProperties
192 @ stdcall vkGetPhysicalDeviceExternalSemaphoreProperties
(ptr ptr ptr
) winevulkan.wine_vkGetPhysicalDeviceExternalSemaphoreProperties
193 @ stdcall vkGetPhysicalDeviceFeatures
(ptr ptr
) winevulkan.wine_vkGetPhysicalDeviceFeatures
194 @ stdcall vkGetPhysicalDeviceFeatures2
(ptr ptr
) winevulkan.wine_vkGetPhysicalDeviceFeatures2
195 @ stdcall vkGetPhysicalDeviceFormatProperties
(ptr long ptr
) winevulkan.wine_vkGetPhysicalDeviceFormatProperties
196 @ stdcall vkGetPhysicalDeviceFormatProperties2
(ptr long ptr
) winevulkan.wine_vkGetPhysicalDeviceFormatProperties2
197 @ stdcall vkGetPhysicalDeviceImageFormatProperties
(ptr long long long long long ptr
) winevulkan.wine_vkGetPhysicalDeviceImageFormatProperties
198 @ stdcall vkGetPhysicalDeviceImageFormatProperties2
(ptr ptr ptr
) winevulkan.wine_vkGetPhysicalDeviceImageFormatProperties2
199 @ stdcall vkGetPhysicalDeviceMemoryProperties
(ptr ptr
) winevulkan.wine_vkGetPhysicalDeviceMemoryProperties
200 @ stdcall vkGetPhysicalDeviceMemoryProperties2
(ptr ptr
) winevulkan.wine_vkGetPhysicalDeviceMemoryProperties2
201 @ stdcall vkGetPhysicalDevicePresentRectanglesKHR
(ptr int64 ptr ptr
) winevulkan.wine_vkGetPhysicalDevicePresentRectanglesKHR
202 @ stdcall vkGetPhysicalDeviceProperties
(ptr ptr
) winevulkan.wine_vkGetPhysicalDeviceProperties
203 @ stdcall vkGetPhysicalDeviceProperties2
(ptr ptr
) winevulkan.wine_vkGetPhysicalDeviceProperties2
204 @ stdcall vkGetPhysicalDeviceQueueFamilyProperties
(ptr ptr ptr
) winevulkan.wine_vkGetPhysicalDeviceQueueFamilyProperties
205 @ stdcall vkGetPhysicalDeviceQueueFamilyProperties2
(ptr ptr ptr
) winevulkan.wine_vkGetPhysicalDeviceQueueFamilyProperties2
206 @ stdcall vkGetPhysicalDeviceSparseImageFormatProperties
(ptr long long long long long ptr ptr
) winevulkan.wine_vkGetPhysicalDeviceSparseImageFormatProperties
207 @ stdcall vkGetPhysicalDeviceSparseImageFormatProperties2
(ptr ptr ptr ptr
) winevulkan.wine_vkGetPhysicalDeviceSparseImageFormatProperties2
208 @ stdcall vkGetPhysicalDeviceSurfaceCapabilitiesKHR
(ptr int64 ptr
) winevulkan.wine_vkGetPhysicalDeviceSurfaceCapabilitiesKHR
209 @ stdcall vkGetPhysicalDeviceSurfaceFormatsKHR
(ptr int64 ptr ptr
) winevulkan.wine_vkGetPhysicalDeviceSurfaceFormatsKHR
210 @ stdcall vkGetPhysicalDeviceSurfacePresentModesKHR
(ptr int64 ptr ptr
) winevulkan.wine_vkGetPhysicalDeviceSurfacePresentModesKHR
211 @ stdcall vkGetPhysicalDeviceSurfaceSupportKHR
(ptr long int64 ptr
) winevulkan.wine_vkGetPhysicalDeviceSurfaceSupportKHR
212 @ stdcall vkGetPhysicalDeviceWin32PresentationSupportKHR
(ptr long
) winevulkan.wine_vkGetPhysicalDeviceWin32PresentationSupportKHR
213 @ stdcall vkGetPipelineCacheData
(ptr int64 ptr ptr
) winevulkan.wine_vkGetPipelineCacheData
214 @ stdcall vkGetQueryPoolResults
(ptr int64 long long long ptr int64 long
) winevulkan.wine_vkGetQueryPoolResults
215 @ stdcall vkGetRenderAreaGranularity
(ptr int64 ptr
) winevulkan.wine_vkGetRenderAreaGranularity
216 @ stdcall vkGetSemaphoreCounterValue
(ptr int64 ptr
) winevulkan.wine_vkGetSemaphoreCounterValue
217 @ stdcall vkGetSwapchainImagesKHR
(ptr int64 ptr ptr
) winevulkan.wine_vkGetSwapchainImagesKHR
218 @ stdcall vkInvalidateMappedMemoryRanges
(ptr long ptr
) winevulkan.wine_vkInvalidateMappedMemoryRanges
219 @ stdcall vkMapMemory
(ptr int64 int64 int64 long ptr
) winevulkan.wine_vkMapMemory
220 @ stdcall vkMergePipelineCaches
(ptr int64 long ptr
) winevulkan.wine_vkMergePipelineCaches
221 @ stdcall vkQueueBindSparse
(ptr long ptr int64
) winevulkan.wine_vkQueueBindSparse
222 @ stdcall vkQueuePresentKHR
(ptr ptr
) winevulkan.wine_vkQueuePresentKHR
223 @ stdcall vkQueueSubmit
(ptr long ptr int64
) winevulkan.wine_vkQueueSubmit
224 @ stdcall vkQueueWaitIdle
(ptr
) winevulkan.wine_vkQueueWaitIdle
225 @ stdcall vkResetCommandBuffer
(ptr long
) winevulkan.wine_vkResetCommandBuffer
226 @ stdcall vkResetCommandPool
(ptr int64 long
) winevulkan.wine_vkResetCommandPool
227 @ stdcall vkResetDescriptorPool
(ptr int64 long
) winevulkan.wine_vkResetDescriptorPool
228 @ stdcall vkResetEvent
(ptr int64
) winevulkan.wine_vkResetEvent
229 @ stdcall vkResetFences
(ptr long ptr
) winevulkan.wine_vkResetFences
230 @ stdcall vkResetQueryPool
(ptr int64 long long
) winevulkan.wine_vkResetQueryPool
231 @ stdcall vkSetEvent
(ptr int64
) winevulkan.wine_vkSetEvent
232 @ stdcall vkSignalSemaphore
(ptr ptr
) winevulkan.wine_vkSignalSemaphore
233 @ stdcall vkTrimCommandPool
(ptr int64 long
) winevulkan.wine_vkTrimCommandPool
234 @ stdcall vkUnmapMemory
(ptr int64
) winevulkan.wine_vkUnmapMemory
235 @ stdcall vkUpdateDescriptorSetWithTemplate
(ptr int64 int64 ptr
) winevulkan.wine_vkUpdateDescriptorSetWithTemplate
236 @ stdcall vkUpdateDescriptorSets
(ptr long ptr long ptr
) winevulkan.wine_vkUpdateDescriptorSets
237 @ stdcall vkWaitForFences
(ptr long ptr long int64
) winevulkan.wine_vkWaitForFences
238 @ stdcall vkWaitSemaphores
(ptr ptr int64
) winevulkan.wine_vkWaitSemaphores