grub2: bring back build of aros-side grub2 tools
[AROS.git] / workbench / libs / mesa / docs / WL_bind_wayland_display.spec
blobe2fde3c507b7c0e900c2648a164db3ee064c1c5c
1 Name
3 WL_bind_wayland_display
5 Name Strings
7 EGL_WL_bind_wayland_display
9 Contact
11 Kristian Høgsberg <krh@bitplanet.net>
12 Benjamin Franzke <benjaminfranzke@googlemail.com>
14 Status
16 Proposal
18 Version
20 Version 1, March 1, 2011
22 Number
24 EGL Extension #not assigned
26 Dependencies
28 Requires EGL 1.4 or later. This extension is written against the
29 wording of the EGL 1.4 specification.
31 EGL_KHR_base_image is required.
33 Overview
35 This extension provides entry points for binding and unbinding the
36 wl_display of a Wayland compositor to an EGLDisplay. Binding a
37 wl_display means that the EGL implementation should provide one or
38 more interfaces in the Wayland protocol to allow clients to create
39 wl_buffer objects. On the server side, this extension also
40 provides a new target for eglCreateImageKHR, to create an EGLImage
41 from a wl_buffer
43 Adding an implementation specific wayland interface, allows the
44 EGL implementation to define specific wayland requests and events,
45 needed for buffer sharing in an EGL wayland platform.
47 IP Status
49 Open-source; freely implementable.
51 New Procedures and Functions
53 EGLBoolean eglBindWaylandDisplayWL(EGLDisplay dpy,
54 struct wl_display *display);
56 EGLBoolean eglUnbindWaylandDisplayWL(EGLDisplay dpy,
57 struct wl_display *display);
59 New Tokens
61 Accepted as <target> in eglCreateImageKHR
63 EGL_WAYLAND_BUFFER_WL 0x31D5
65 Additions to the EGL 1.4 Specification:
67 To bind a server side wl_display to an EGLDisplay, call
69 EGLBoolean eglBindWaylandDisplayWL(EGLDisplay dpy,
70 struct wl_display *display);
72 To unbind a server side wl_display from an EGLDisplay, call
74 EGLBoolean eglUnbindWaylandDisplayWL(EGLDisplay dpy,
75 struct wl_display *display);
77 eglBindWaylandDisplayWL returns EGL_FALSE when there is already a
78 wl_display bound to EGLDisplay otherwise EGL_TRUE.
80 eglUnbindWaylandDisplayWL returns EGL_FALSE when there is no
81 wl_display bound to the EGLDisplay currently otherwise EGL_TRUE.
83 Import a wl_buffer by calling eglCreateImageKHR with
84 wl_buffer as EGLClientBuffer, EGL_WAYLAND_BUFFER_WL as the target,
85 NULL context and an empty attribute_list.
87 Issues
89 Revision History
91 Version 1, March 1, 2011
92 Initial draft (Benjamin Franzke)