Check for SYS/GL during library init. Reason is that
[AROS.git] / workbench / libs / mesa / docs / MESA_set_3dfx_mode.spec
blob06d97ca021feb846c00f72886d18cd5158000a4d
1 Name
3 MESA_set_3dfx_mode
5 Name Strings
7 GLX_MESA_set_3dfx_mode
9 Contact
11 Brian Paul (brian.paul 'at' tungstengraphics.com)
13 Status
15 Shipping since Mesa 2.6 in February, 1998.
17 Version
19 Last Modified Date: 8 June 2000
21 Number
23 218
25 Dependencies
27 OpenGL 1.0 or later is required.
28 GLX 1.0 or later is required.
30 Overview
32 The Mesa Glide driver allows full-screen rendering or rendering into
33 an X window. The glXSet3DfxModeMESA() function allows an application
34 to switch between full-screen and windowed rendering.
36 IP Status
38 Open-source; freely implementable.
40 Issues
42 None.
44 New Procedures and Functions
46 GLboolean glXSet3DfxModeMESA( GLint mode );
48 New Tokens
50 GLX_3DFX_WINDOW_MODE_MESA 0x1
51 GLX_3DFX_FULLSCREEN_MODE_MESA 0x2
53 Additions to Chapter 3 of the GLX 1.3 Specification (Functions and Errors)
55 The Mesa Glide device driver allows either rendering in full-screen
56 mode or rendering into an X window. An application can switch between
57 full-screen and window rendering with the command:
59 GLboolean glXSet3DfxModeMESA( GLint mode );
61 <mode> may either be GLX_3DFX_WINDOW_MODE_MESA to indicate window
62 rendering or GLX_3DFX_FULLSCREEN_MODE_MESA to indicate full-screen mode.
64 GL_TRUE is returned if <mode> is valid and the operation completed
65 normally. GL_FALSE is returned if <mode> is invalid or if the Glide
66 driver is not being used.
68 Note that only one drawable and context can be created at any given
69 time with the Mesa Glide driver.
71 GLX Protocol
73 None since this is a client-side extension.
75 Errors
77 None.
79 New State
81 None.
83 Revision History
85 8 June 2000 - initial specification