1 # Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
4 # acme -V says version 0.97, but the source repo has no branches or tags
7 pkgdesc='Assembler for the 6502, 6510, 65c02 and 65816 processors'
9 url='https://sourceforge.net/projects/acme-crossass/'
11 makedepends=(setconf subversion)
13 source=("$pkgname::svn+https://svn.code.sf.net/p/acme-crossass/code-0/trunk#revision=r324")
18 setconf Makefile CFLAGS "$CFLAGS -w"
19 setconf Makefile LIBS "$LDFLAGS -lm"
28 install -Dm755 src/acme "$pkgdir/usr/bin/acme"
29 install -d "$pkgdir/usr/share/doc/acme"
30 install -t "$pkgdir/usr/share/doc/acme" docs/*.txt
31 # Joe syntax highlighting
32 install -Dm644 contrib/joe_syntax/acme.jsf \
33 "$pkgdir/usr/share/joe/syntax/acme.jsf"
34 install -Dm644 contrib/joe_syntax/INSTALL \
35 "$pkgdir/usr/share/doc/acme/joe.txt"
37 chmod 644 "$pkgdir/usr/share/doc/acme/"*