upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / acme / trunk / PKGBUILD
blob31d2e898289277072357e31554575539f6c7e110
1 # Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
3 pkgname=acme
4 # acme -V says version 0.97, but the source repo has no branches or tags
5 pkgver=2023.03.05
6 pkgrel=1
7 pkgdesc='Assembler for the 6502, 6510, 65c02 and 65816 processors'
8 arch=(x86_64)
9 url='https://sourceforge.net/projects/acme-crossass/'
10 license=(GPL)
11 makedepends=(setconf subversion)
12 conflicts=(plan9port)
13 source=("$pkgname::svn+https://svn.code.sf.net/p/acme-crossass/code-0/trunk#revision=r324")
14 b2sums=('SKIP')
16 prepare() {
17   cd $pkgname/src
18   setconf Makefile CFLAGS "$CFLAGS -w"
19   setconf Makefile LIBS "$LDFLAGS -lm"
22 build() {
23   make -C $pkgname/src
26 package() {
27   cd $pkgname
28   install -Dm755 src/acme "$pkgdir/usr/bin/acme"
29   install -d "$pkgdir/usr/share/doc/acme"
30   install -t "$pkgdir/usr/share/doc/acme" docs/*.txt
31   # Joe syntax highlighting
32   install -Dm644 contrib/joe_syntax/acme.jsf \
33     "$pkgdir/usr/share/joe/syntax/acme.jsf"
34   install -Dm644 contrib/joe_syntax/INSTALL \
35     "$pkgdir/usr/share/doc/acme/joe.txt"
36   # FS#69332
37   chmod 644 "$pkgdir/usr/share/doc/acme/"*