upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / amtk / repos / community-x86_64 / PKGBUILD
bloba7bbacc1b328dbbf105ded9424cf1af851e665b5
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Balló György <ballogyor+arch at gmail dot com>
4 pkgname=amtk
5 pkgver=5.6.1
6 pkgrel=1
7 pkgdesc="Actions, Menus and Toolbars Kit for GTK applications"
8 url="https://gitlab.gnome.org/World/amtk"
9 arch=(x86_64)
10 license=(LGPL3)
11 depends=(gtk3)
12 makedepends=(meson git gobject-introspection gtk-doc)
13 options=(debug)
14 _commit=f0029cf75ec416159079a27b578b9253a04b1c5a
15 source=("git+https://gitlab.gnome.org/World/amtk.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd amtk
20   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd amtk
27 build() {
28   arch-meson amtk build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   depends+=(libg{lib,object,io}-2.0.so libgtk-3.so)
38   provides+=("libamtk-${pkgver%%.*}.so")
40   meson install -C build --destdir "$pkgdir"