upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / antiword / repos / community-x86_64 / PKGBUILD
blob0aeb175d61d75ebfba8e29bd5a8078a5821aaa24
1 # Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
2 # Contributor: Aaron, phrakture, Griffin <aaron@archlinux.org>
3 # Contributor: Gustav Munkby <grddev@gmx.net>
5 pkgname=antiword
6 pkgver=0.37
7 pkgrel=9
8 pkgdesc="A free MS Word reader for Linux and RISC OS"
9 arch=('x86_64')
10 url="http://www.winfield.demon.nl/"
11 license=('GPL')
12 depends=('bash')
13 source=("http://www.winfield.demon.nl/linux/$pkgname-$pkgver.tar.gz"
14         '10_fix_buffer_overflow_wordole_c.patch')
15 md5sums=('f868e2a269edcbc06bf77e89a55898d1'
16          '3eb02e9d913b355d64d9a30b08fc390f')
17 sha256sums=('8e2c000fcbc6d641b0e6ff95e13c846da3ff31097801e86702124a206888f5ac'
18             '9ffa1a21be3fd639fb5a779f2155735574dea75cee8d67228669cf18508235e1')
20 prepare() {
21   cd "$srcdir/$pkgname-$pkgver"
22   patch -p1 -i ../10_fix_buffer_overflow_wordole_c.patch
25 build() {
26   cd "$srcdir/$pkgname-$pkgver"
28   sed -i "s|GLOBAL_INSTALL_DIR =.*|GLOBAL_INSTALL_DIR = /usr/bin|g" Makefile.Linux
29   make OPT="$CFLAGS -DNDEBUG" LDFLAGS="$LDFLAGS"
32 package() {
33   cd "$srcdir/$pkgname-$pkgver"
35   make DESTDIR="$pkgdir" global_install
36   install -Dm644 Docs/antiword.1 "$pkgdir/usr/share/man/man1/antiword.1"