1 # Maintainer: Laurent Carlier <lordheavym@gmail.com>
2 # Contributor: Luca Bennati <lucak3 AT gmail DOT com>
3 # Contributor: Glaucous <glakke1 at gmail dot com>
8 pkgdesc="Graphics API Tracing"
10 url="https://github.com/apitrace/apitrace"
12 makedepends=('cmake' 'git' 'mesa' 'qt5-base')
13 depends=('python' 'libgl' 'procps-ng')
14 optdepends=('qt5-base: GUI support')
15 source=("$pkgname-$pkgver::git+https://github.com/apitrace/apitrace.git#tag=${pkgver}")
21 git submodule update --init --depth 1 --recursive
27 cmake . -Bbuild -DCMAKE_INSTALL_PREFIX=/usr \
35 make -C build DESTDIR="${pkgdir}/" install
37 install -m755 -d "${pkgdir}/usr/share/licenses/apitrace"
38 install -m644 LICENSE "${pkgdir}/usr/share/licenses/apitrace/"