1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
6 pkgdesc="Automatic Rule-Based Time Tracker"
7 url="http://arbtt.nomeata.de/"
10 depends=('ghc-libs' 'haskell-x11' 'haskell-aeson' 'haskell-attoparsec' 'haskell-bytestring-progress'
11 'haskell-conduit' 'haskell-pcre-light' 'haskell-resourcet' 'haskell-strict'
12 'haskell-terminal-progress-bar' 'haskell-tz' 'haskell-unliftio-core' 'haskell-utf8-string')
13 makedepends=('ghc' 'haskell-process-extras' 'haskell-tasty' 'haskell-tasty-golden'
14 'haskell-tasty-hunit')
15 source=("https://hackage.haskell.org/packages/archive/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz")
16 sha256sums=('b81b5f67d6774c23eee8d662109179a7307eabbb44b666036512898dde524fa8')
21 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
22 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --datasubdir=haskell-arbtt --enable-tests \
23 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
24 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
27 runhaskell Setup build $MAKEFLAGS
33 for _exe in arbtt-{dump,import,recover,stats}; do
34 PATH="$PWD/dist/build/$_exe:$PATH"
36 runhaskell Setup test --show-details=direct
43 runhaskell Setup copy --destdir="$pkgdir"
44 install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
45 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE