upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / arm-none-eabi-binutils / trunk / PKGBUILD
blobc684a2e93546345536f41669b7a7f6be0739492d
1 # Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
2 # Contributor: Martin Schmölzer <mschmoelzer@gmail.com>
4 _target=arm-none-eabi
5 pkgname=$_target-binutils
6 pkgver=2.40
7 pkgrel=1
8 pkgdesc='A set of programs to assemble and manipulate binary and object files for the ARM EABI (bare-metal) target'
9 arch=(x86_64)
10 url='https://www.gnu.org/software/binutils/'
11 license=(GPL)
12 depends=(zlib libelf)
13 source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2{,.sig})
14 sha1sums=('887d24c3799e9fe02646e04e73b5ac2cc3e7188f'
15           'SKIP')
16 sha256sums=('f8298eb153a4b37d112e945aa5cb2850040bcf26a3ea65b5a715c83afe05e48a'
17             'SKIP')
18 validpgpkeys=('3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F') # Nick Clifton (Chief Binutils Maintainer) <nickc@redhat.com>
20 prepare() {
21   cd binutils-$pkgver
22   sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
25 build() {
26   cd binutils-$pkgver
28   ./configure --target=$_target \
29               --with-sysroot=/usr/$_target \
30               --prefix=/usr \
31               --enable-multilib \
32               --enable-interwork \
33               --with-gnu-as \
34               --with-gnu-ld \
35               --disable-nls \
36               --enable-ld=default \
37               --enable-gold \
38               --enable-plugins \
39               --enable-deterministic-archives
41   make
44 check() {
45   cd binutils-$pkgver
47   # unset LDFLAGS as testsuite makes assumptions about which ones are active
48   # do not abort on errors - manually check log files
49   make LDFLAGS="" -k check || true
52 package() {
53   cd binutils-$pkgver
55   make DESTDIR="$pkgdir" install
57   # Remove file conflicting with host binutils and manpages for MS Windows tools
58   rm "$pkgdir"/usr/share/man/man1/arm-none-eabi-{dlltool,windres,windmc}*
59   rm "$pkgdir"/usr/lib/bfd-plugins/libdep.so
61   # Remove info documents that conflict with host version
62   rm -r "$pkgdir"/usr/share/info