upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / asciinema / trunk / PKGBUILD
blob8f7d0bec549f6bac9ad13da5652e10884179c8ab
1 # Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
2 # Contributor: Marcin Kulik <marcin@asciinema.org>
4 pkgname=asciinema
5 pkgver=2.2.0
6 pkgrel=3
7 pkgdesc='Record and share terminal sessions'
8 arch=(any)
9 url='https://asciinema.org/'
10 license=(GPL3)
11 depends=(python)
12 makedepends=(git python-setuptools python-wheel python-build python-installer)
13 source=('git+https://github.com/asciinema/asciinema#commit=f3af768f569e0b363bcced11d266d4ed857e21e7') # tag: v2.1.0
14 b2sums=(SKIP)
16 prepare() {
17   echo -e '#!/bin/sh\n/usr/bin/python -m asciinema "$@"' > "$pkgname/asciinema.sh"
20 build() {
21   cd $pkgname
22   python -m build --wheel --no-isolation
25 package() {
26   cd $pkgname
27   install -Dm755 -t "$pkgdir/usr/bin" asciinema.sh
28   python -m installer --destdir="$pkgdir" dist/*.whl
31 # getver: raw.githubusercontent.com/asciinema/asciinema/master/asciinema/__init__.py