1 # Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
2 # Contributor: Marcin Kulik <marcin@asciinema.org>
7 pkgdesc='Record and share terminal sessions'
9 url='https://asciinema.org/'
12 makedepends=(git python-setuptools python-wheel python-build python-installer)
13 source=('git+https://github.com/asciinema/asciinema#commit=f3af768f569e0b363bcced11d266d4ed857e21e7') # tag: v2.1.0
17 echo -e '#!/bin/sh\n/usr/bin/python -m asciinema "$@"' > "$pkgname/asciinema.sh"
22 python -m build --wheel --no-isolation
27 install -Dm755 -t "$pkgdir/usr/bin" asciinema.sh
28 python -m installer --destdir="$pkgdir" dist/*.whl
31 # getver: raw.githubusercontent.com/asciinema/asciinema/master/asciinema/__init__.py