upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / aws-c-io / trunk / PKGBUILD
blob98279543836fe5a7aec0bc52e6ed01fee42e2401
1 # Maintainer: Anatol Pomozov
3 pkgname=aws-c-io
4 pkgver=0.13.21
5 pkgrel=1
6 pkgdesc='AWS SDK module to handle all IO and TLS work for application protocols'
7 arch=(x86_64)
8 url='https://github.com/awslabs/aws-c-io'
9 license=(Apache)
10 depends=(aws-c-common aws-c-cal s2n-tls)
11 makedepends=(cmake)
12 source=(aws-c-io-$pkgver.zip::https://github.com/awslabs/aws-c-io/archive/v$pkgver.zip)
13 sha256sums=('1dee7a0c20a3361e7a0fae24b766bec9e81e813782a55423a0460f9fc7bfb732')
15 build() {
16   cd aws-c-io-$pkgver
18   cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_SHARED_LIBS=ON -S . -B build
19   cmake --build build
22 check() {
23   cd aws-c-io-$pkgver
24   cmake --build build --target test --verbose
27 package() {
28   cd aws-c-io-$pkgver
30   cmake --build build --target install -- DESTDIR="$pkgdir/"
31   install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"