upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / aws-crt-cpp / trunk / PKGBUILD
blob6102207e52abddf61b2e37d727173af06fd94e59
1 # Maintainer: Anatol Pomozov
3 pkgname=aws-crt-cpp
4 pkgver=0.20.0
5 pkgrel=1
6 pkgdesc='C++ wrapper around the aws-c-* libraries. Provides Cross-Platform Transport Protocols and SSL/TLS implementations for C++.'
7 arch=(x86_64)
8 url='https://github.com/awslabs/aws-crt-cpp'
9 license=(Apache)
10 depends=(gcc-libs aws-c-common aws-c-http aws-c-mqtt aws-c-auth aws-c-s3 aws-c-event-stream)
11 makedepends=(cmake)
12 source=(aws-crt-cpp-$pkgver.zip::https://github.com/awslabs/aws-crt-cpp/archive/v$pkgver.zip)
13 sha256sums=('4aaab8baa447247248d79f6b4ad866e09a8941e3304da894f8b266e94c6d6dcb')
15 build() {
16   cd aws-crt-cpp-$pkgver
18   cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_SHARED_LIBS=ON -DBUILD_DEPS=OFF -S . -B build
19   cmake --build build
22 check() {
23   cd aws-crt-cpp-$pkgver
24   cmake --build build --target test
27 package() {
28   cd aws-crt-cpp-$pkgver
30   cmake --build build --target install -- DESTDIR="$pkgdir/"
31   install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"