1 # Maintainer: Anatol Pomozov
6 pkgdesc='C++ wrapper around the aws-c-* libraries. Provides Cross-Platform Transport Protocols and SSL/TLS implementations for C++.'
8 url='https://github.com/awslabs/aws-crt-cpp'
10 depends=(gcc-libs aws-c-common aws-c-http aws-c-mqtt aws-c-auth aws-c-s3 aws-c-event-stream)
12 source=(aws-crt-cpp-$pkgver.zip::https://github.com/awslabs/aws-crt-cpp/archive/v$pkgver.zip)
13 sha256sums=('4aaab8baa447247248d79f6b4ad866e09a8941e3304da894f8b266e94c6d6dcb')
16 cd aws-crt-cpp-$pkgver
18 cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_SHARED_LIBS=ON -DBUILD_DEPS=OFF -S . -B build
23 cd aws-crt-cpp-$pkgver
24 cmake --build build --target test
28 cd aws-crt-cpp-$pkgver
30 cmake --build build --target install -- DESTDIR="$pkgdir/"
31 install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"