upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / bandit / repos / community-any / PKGBUILD
blob1da97f873f8dac94b61b2d112ffd7aacda8778c7
1 # Maintainer: Jelle van der Waa <jelle@archlinux.org>
3 pkgname=bandit
4 pkgver=1.7.5
5 pkgrel=4
6 pkgdesc='Python security linter from OpenStack Security'
7 arch=('any')
8 url='https://github.com/PyCQA/bandit'
9 license=('Apache')
10 depends=('python-yaml' 'python-stevedore' 'python-six' 'python-pbr' 'python-gitpython' 'python-rich')
11 makedepends=('python-setuptools' 'git')
12 source=(https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz)
13 sha512sums=('81b93654ba62e6d22e8c2d534b9f575979bad4f66acd90c221d214316cd1863e7c7e179b8e2a2a8fa80034db71ebda8636adb25b36e1827194bb4639e67ada09')
15 build() {
16     cd bandit-$pkgver
17     python setup.py build
20 package() {
21     cd bandit-$pkgver
22     python setup.py install --root="$pkgdir" --skip-build --optimize=1