upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / bonzomatic / trunk / PKGBUILD
blobf1db90388bef18368ce25bb28a7fe3aea1215828
1 # Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
2 # Contributor: Robin Broda <robin at broda dot me>
4 pkgname=bonzomatic
5 pkgver=1.0.20220820
6 pkgrel=1
7 pkgdesc='Live shader coding tool'
8 arch=(x86_64)
9 url='https://github.com/Gargaj/bonzomatic'
10 license=(Custom:Unlicense)
11 depends=(alsa-lib fontconfig hicolor-icon-theme libglvnd)
12 makedepends=(chrpath cmake git glu imagemagick libxcursor libxi libxinerama libxrandr ninja)
13 source=("$pkgname::git+$url#commit=b74363c602614460f2b5ea51b99c5f1096333407") # tag: 2022-08-20
14 b2sums=(SKIP)
16 prepare() {
17   convert "$pkgname/data/unix/icon.png" -resize 128x128 "$srcdir/$pkgname.png"
20 build() {
21   cmake \
22     -B build \
23     -D CMAKE_C_FLAGS="$CFLAGS -fPIC -w" \
24     -D CMAKE_CXX_FLAGS="$CFLAGS -fPIC -w" \
25     -D CMAKE_INSTALL_LIBDIR=lib \
26     -D CMAKE_INSTALL_PREFIX=/usr \
27     -G Ninja \
28     -S $pkgname
29   ninja -C build
32 package() {
33   DESTDIR="$pkgdir" ninja -C build install
35   # Fix insecure rpath
36   chrpath -d "$pkgdir/usr/bin/bonzomatic"
38   # Package license
39   install -Dm644 $pkgname/LICENSE \
40     "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
42   # Package desktop icon
43   install -Dm644 $pkgname.png "$pkgdir/usr/share/pixmaps/$pkgname.png"