upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / brial / trunk / PKGBUILD
blob744e3afc76d76f0dec994ac7ba9b622ff375da62
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=brial
4 pkgver=1.2.12
5 pkgrel=2
6 pkgdesc='Library for polynomials over boolean rings'
7 arch=(x86_64)
8 url='https://github.com/BRiAl/BRiAl'
9 license=(GPL)
10 depends=(m4ri)
11 makedepends=(boost)
12 source=(https://github.com/BRiAl/BRiAl/releases/download/$pkgver/brial-$pkgver.tar.bz2)
13 sha256sums=('ca009e3722dd3f0a60d15501caed1413146c80abced57423e32ae0116f407494')
15 build() {
16   cd $pkgname-$pkgver 
18   ./configure --prefix=/usr --enable-shared
19   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool # https://bugzilla.gnome.org/show_bug.cgi?id=655517
20   make
23 check() {
24   cd $pkgname-$pkgver
25   make check
28 package() {
29   cd $pkgname-$pkgver
31   make DESTDIR="$pkgdir" install