1 # Maintainer: Sven-Hendrik Haase <svenstaro@archlinux.org>
2 # Maintainer: Orhun Parmaksız <orhun@archlinux.org>
3 # Contributor: Adam Fontenot <adam.m.fontenot@gmail.com>
4 # Contributor: Daniel M. Capella <polyzen@archlinux.org>
9 pkgdesc='Fuzzy Search + tree + cd'
11 url=https://github.com/Canop/broot
13 depends=('gcc-libs' 'zlib' 'libgit2' 'libxcb')
16 source=("https://github.com/Canop/broot/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
17 sha256sums=('6c612c596e467e610c7a80b4f086d9443e2b5040edcfa1bdda129aa715bb64d9')
21 cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
26 cargo build --release --frozen --features clipboard
36 install -Dt "$pkgdir"/usr/bin target/release/$pkgname
37 sed -i "s/#version/$pkgver/" man/page
38 # Theoretically we could get the date from the CHANGELOG.md but it seems that the
39 # CHANGELOG.md entry for the current version isn't actually in the current release.
40 # changelog_date=$(sed -n "s/.*v$pkgver - \(.*\)$/\1/p" CHANGELOG.md)
41 sed -i "s/#date//" man/page
42 install -Dm644 man/page "$pkgdir/usr/share/man/man1/$pkgname.1"
43 install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
44 install -Dm644 resources/icons/vscode/vscode.ttf "$pkgdir/usr/share/fonts/TTF/vscode.ttf"
47 # vim:set ts=2 sw=2 et: