1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Llewelyn Trahaearn <WoefulDerelict [at] GMail [dot] com>
3 # Contributor: falkTX <falktx [at] gmail [dot] com>
7 _commit=4a6dc504be5d547a97079bf3400a85f9080177db # refs/tags/v2.5.4
10 pkgdesc="Audio Plugin Host"
12 url="https://kxstudio.linuxaudio.org/Applications:Carla"
40 'jack: for using carla with JACK'
41 'lv2-host: for the LV2 plugin'
42 'vst-host: for the VST plugin'
44 provides=(dssi-host ladspa-host lv2-host vst-host vst3-host)
45 source=(git+https://github.com/falkTX/$pkgname#tag=$_commit?signed)
48 validpgpkeys=('62B11043D2F6EB6672D93103CDBAA37ABC74FBA0') # falkTX <falktx@falktx.com>
52 # fix issues with python-pyqt5
53 git cherry-pick -n 4151e160f1e9e03412c112fec54b5f1cde4c45de
57 make features -C $pkgname
65 fluidsynth libfluidsynth.so
66 freetype2 libfreetype.so
69 libpulse libpulse.so libpulse-simple.so
70 libsndfile libsndfile.so
73 make DEFAULT_QT=5 DESTDIR="$pkgdir" PREFIX=/usr install -C $pkgname
74 install -vDm 644 $pkgname/README.md -t "$pkgdir/usr/share/doc/$pkgname/"
75 find "$pkgdir" -type f -iname "*.so" -exec chmod +x {} +
77 # vim:set ts=2 sw=2 et: