upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / certbot-dns-luadns / repos / community-any / PKGBUILD
blobc9d7710ba2d9493ab6ebaa7e8863532bed10888f
1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: Felix Yan <felixonmars@archlinux.org>
4 pkgname=certbot-dns-luadns
5 pkgver=2.6.0
6 pkgrel=1
7 pkgdesc='LuaDNS DNS Authenticator plugin for Certbot'
8 arch=('any')
9 license=('Apache')
10 url='https://pypi.python.org/pypi/certbot-dns-luadns'
11 depends=(
12   "certbot=$pkgver"
13   "python-acme=$pkgver"
14   'dns-lexicon'
16 makedepends=(
17   'git'
18   'python-build'
19   'python-wheel'
20   'python-installer'
22 checkdepends=('python-pytest')
23 # git repository is used because certbot is a huge monorepo and it's easier to
24 # share the entire repository across all certbot related packages than a few
25 # hundred tarballs.
26 _commit='013621d04ed26377cf6616448b21a4c050683719'
27 _repo='github.com-certbot-certbot'
28 source=("$_repo::git+https://github.com/certbot/certbot#commit=$_commit")
29 b2sums=('SKIP')
31 pkgver() {
32   cd "$_repo"
34   git describe --tags | sed 's/^v//'
37 prepare() {
38   cd "$_repo/$pkgname"
40   # nuke setuptools from orbit ^W install_requires
41   sed \
42     -e '/setuptools>=/d' \
43     -i setup.py
46 build() {
47   cd "$_repo/$pkgname"
49   python -m build --wheel --no-isolation
52 check() {
53   cd "$_repo/$pkgname"
55   # https://github.com/certbot/certbot/issues/9606
56   pytest -v -W ignore::DeprecationWarning
59 package() {
60   cd "$_repo/$pkgname"
62   python -m installer --destdir="$pkgdir" dist/*.whl