1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: Felix Yan <felixonmars@archlinux.org>
4 pkgname=certbot-dns-luadns
7 pkgdesc='LuaDNS DNS Authenticator plugin for Certbot'
10 url='https://pypi.python.org/pypi/certbot-dns-luadns'
22 checkdepends=('python-pytest')
23 # git repository is used because certbot is a huge monorepo and it's easier to
24 # share the entire repository across all certbot related packages than a few
26 _commit='013621d04ed26377cf6616448b21a4c050683719'
27 _repo='github.com-certbot-certbot'
28 source=("$_repo::git+https://github.com/certbot/certbot#commit=$_commit")
34 git describe --tags | sed 's/^v//'
40 # nuke setuptools from orbit ^W install_requires
42 -e '/setuptools>=/d' \
49 python -m build --wheel --no-isolation
55 # https://github.com/certbot/certbot/issues/9606
56 pytest -v -W ignore::DeprecationWarning
62 python -m installer --destdir="$pkgdir" dist/*.whl