1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
8 pkgdesc='Nginx plugin for Certbot'
11 url='https://pypi.python.org/pypi/certbot-nginx'
25 checkdepends=('python-pytest')
26 # git repository is used because certbot is a huge monorepo and it's easier to
27 # share the entire repository across all certbot related packages than a few
29 _commit='013621d04ed26377cf6616448b21a4c050683719'
30 _repo='github.com-certbot-certbot'
31 source=("$_repo::git+https://github.com/certbot/certbot#commit=$_commit")
37 git describe --tags | sed 's/^v//'
43 # nuke setuptools from orbit ^W install_requires
45 -e '/setuptools>=/d' \
52 python -m build --wheel --no-isolation
58 # https://github.com/certbot/certbot/issues/9606
59 pytest -v -W ignore::DeprecationWarning
65 python -m installer --destdir="$pkgdir" dist/*.whl