upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / cmt / trunk / PKGBUILD
blob676bcb51eee409a4013b4a19d118970c1da31006
1 #Maintainer: David Runge <dvzrv@archlinux.org>
2 #Contributor: Damir Perisa <damir.perisa@bluewin.ch>
3 #Contributor: Robert Emil Berge <robert@rebi.no>
5 pkgname=cmt
6 pkgver=1.18
7 pkgrel=3
8 pkgdesc="LADSPA plugins for use with software synthesis and recording packages on Linux"
9 arch=(x86_64)
10 license=(GPL2)
11 url="https://www.ladspa.org/cmt/overview.html"
12 groups=(
13   ladspa-plugins
14   pro-audio
16 depends=(
17   gcc-libs
18   glibc
20 makedepends=(ladspa)
21 source=(https://www.ladspa.org/download/${pkgname}_$pkgver.tgz)
22 sha512sums=('8ad8b62bd74f521274a729810e6fd61da9d56b571ef8a13104fe8855c8e29cb5cd6b4c75ea69d0f224807418136c504e26948e8da0513d8ce9e6e31e4cb7d4c5')
23 b2sums=('d071d0b6f39fd2ecf562053a878d21e3895a4960f28ed4e6a7cf5d582c4beec6acc571148d054a1a65d78b0497300f18b9b5a05d95afaa64eac1ab56d60c874d')
25 prepare(){
26   # inserting CFLAGS and LDFLAGS for full RELRO
27   sed -e "s|-O2|${CFLAGS} ${LDFLAGS}|" -i ${pkgname}_$pkgver/src/Makefile
30 build() {
31   make -C ${pkgname}_$pkgver/src
34 package() {
35   install -vDm 755 ${pkgname}_$pkgver/plugins/cmt.so -t "$pkgdir/usr/lib/ladspa/"
36   install -vDm 644 ${pkgname}_$pkgver/{README,doc/*.html} -t "$pkgdir/usr/share/doc/$pkgname/"