1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
6 pkgdesc="A cross platform serial debug tools written by python"
8 url="https://github.com/Neutree/COMTool"
10 depends=('python-pyqt5' 'python-pyserial' 'python-requests' 'python-babel')
11 makedepends=('python-setuptools')
12 source=("$pkgname-$pkgver.tar.gz::https://github.com/Neutree/COMTool/archive/v$pkgver.tar.gz")
13 sha512sums=('6d9f65edd5fcccb9e1efa87a46a441b0d6ffb934b176e61a4df1750e3c84f846c2101507ff182606356de48e8967ea507f258174f7ca26836951d4e724290e27')
17 sed -i "s/'pyqt5>=5',//" setup.py
27 python setup.py install -O1 --prefix=/usr --root="$pkgdir"
29 rm "$pkgdir"/usr/{LICENSE,README.MD}
32 # vim:set ts=2 sw=2 et: