1 # Maintainer: Jelle van der Waa <jelle@archlinux.org>
2 # Contributor: Grey Christoforo <first name [at] last name [dot] net>
7 pkgdesc="Engine for processing 3D models into 3D printing instruction for Ultimaker and other GCode based 3D printers."
8 url="https://github.com/Ultimaker/CuraEngine"
11 depends=('arcus' 'polyclipping')
12 checkdepends=('cppunit')
13 makedepends=('cmake' 'git' 'gtest' 'rapidjson')
14 source=("$pkgname-$pkgver.tar.gz::https://github.com/Ultimaker/${pkgname}/archive/${pkgver}.tar.gz")
15 sha512sums=('224379a40e26ae0026a3849d582353e49edf99520401e1fef56c9504638c68c62cfe394dab0eb40e4a447bfe0bfa506a880512e84fd6057a839b6384087c46d0')
19 cd CuraEngine-${pkgver}
24 -DCMAKE_INSTALL_PREFIX=/usr \
26 -DUSE_SYSTEM_LIBS=ON \
27 -DCMAKE_BUILD_TYPE='None'
33 cd CuraEngine-${pkgver}/build
34 # This test fails in when instance->readMeshGroupMessage(mesh_message) is
35 # called in the buildchroot but not outside
36 ARGS="-E ArcusCommunicationPrivateTest" make test
40 cd CuraEngine-${pkgver}/build
41 make DESTDIR="${pkgdir}" install
44 # vim:set ts=2 sw=2 et: