upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / d2 / trunk / PKGBUILD
blob74d3948edf093f6c01209919b004af5f20630442
1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
3 pkgname=d2
4 pkgver=0.4.2
5 pkgrel=1
6 pkgdesc='A modern diagram scripting language that turns text to diagrams'
7 arch=('x86_64')
8 url='https://d2lang.com'
9 license=('MPL2')
10 depends=('glibc' 'gcc-libs')
11 makedepends=('git' 'go')
12 options=('!lto')
13 _commit='65a9e43e96be29422c8481c640711cbce960e106'
14 source=("$pkgname::git+https://github.com/terrastruct/d2#commit=$_commit")
15 b2sums=('SKIP')
17 pkgver() {
18   cd "$pkgname"
20   git describe --tags | sed 's/^v//'
23 prepare() {
24   cd "$pkgname"
26   # create directory for build output
27   mkdir build
29   # download dependencies
30   export GOPATH="${srcdir}"
31   go mod download
34 build() {
35   cd "$pkgname"
37   # set Go flags
38   export CGO_CPPFLAGS="${CPPFLAGS}"
39   export CGO_CFLAGS="${CFLAGS}"
40   export CGO_CXXFLAGS="${CXXFLAGS}"
41   export GOPATH="${srcdir}"
43   go build -v \
44     -buildmode=pie \
45     -mod=readonly \
46     -modcacherw \
47     -ldflags "-compressdwarf=false \
48     -linkmode external \
49     -extldflags ${LDFLAGS} \
50     -X oss.terrastruct.com/d2/lib/version.Version=$pkgver" \
51     -o build \
52     .
55 package() {
56   cd "$pkgname"
58   # binary
59   install -vDm755 -t "$pkgdir/usr/bin" build/d2
61   # man page
62   install -vDm644 -t "$pkgdir/usr/share/man/man1" ci/release/template/man/d2.1
64   # documentation
65   install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md
66   cp -vr docs "$pkgdir/usr/share/doc/$pkgname"
68   # license
69   install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE.txt