upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / dbc-parser-cpp / repos / community-x86_64 / PKGBUILD
blob982c5ecd4d41306ad02cf46bf53b09f73cd5070d
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=dbc-parser-cpp
4 pkgver=0.1.1.r88.ca69d0d
5 pkgrel=1
6 _commit=ca69d0dd08a03fc0210820a4f81bfd217ad25722
7 pkgdesc='A DBC file parsing library written in C++'
8 arch=(x86_64)
9 license=(MIT)
10 url='https://github.com/LinuxDevon/dbc_parser_cpp'
11 depends=()
12 makedepends=(git cmake catch2)
13 source=(git+https://github.com/LinuxDevon/dbc_parser_cpp#commit=$_commit)
14 sha256sums=('SKIP')
16 pkgver() {
17   cd ${pkgname//-/_}
18   git describe --tags | sed 's/^v//; s/-/.r/; s/-g/./'
21 build() {
22   cmake -B build -S ${pkgname//-/_} \
23     -DCMAKE_INSTALL_PREFIX=/usr \
24     -DCMAKE_CXX_FLAGS="$CXXFLAGS -ffat-lto-objects"
25   cmake --build build
28 package() {
29   DESTDIR="$pkgdir" cmake --install build
30   install -Dm644 ${pkgname//-/_}/LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname