upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / ddgr / repos / community-any / PKGBUILD
blobc9cbc5fa1f0128167818302fe20d864692930944
1 # Maintainer: Robin Candau <antiz@archlinux.org>
2 # Contributor: Pablo Arias <pabloariasal[at]gmail[dot]com>
3 # Contributor: John Jenkins <twodopeshaggy[at]gmail[dot]com>
5 pkgname=ddgr
6 pkgver=2.1
7 pkgrel=4
8 pkgdesc="DuckDuckGo from the terminal"
9 arch=('any')
10 url="https://github.com/jarun/ddgr"
11 license=('GPL3')
12 depends=('python>=3.7.0')
13 source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
14 sha256sums=('fb6601ad533f2925d2d6299ab9e6dd48da0b75e99ef9ed9068f37e516380b5e6')
16 package() {
17         cd "${pkgname}-${pkgver}"
19         make PREFIX=/usr DESTDIR="${pkgdir}" install
21         install -Dm 644 "auto-completion/fish/${pkgname}.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/${pkgname}.fish"
22         install -Dm 644 "auto-completion/bash/${pkgname}-completion.bash" "${pkgdir}/usr/share/bash-completion/completions/${pkgname}"
23         install -Dm 644 "auto-completion/zsh/_${pkgname}" "${pkgdir}/usr/share/zsh/site-functions/_${pkgname}"