1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Josip Ponjavic <josipponjavic at gmail dot com>
3 # Contributor: Xu Fasheng <fasheng.xu[AT]gmail.com>
7 _commit=24f095570e5f864c11d2ed7a6560cc69a3ce31c5
9 pkgdesc='Daemon handling the DDE session settings'
11 url="https://github.com/linuxdeepin/dde-daemon"
13 depends=('deepin-desktop-schemas' 'deepin-api' 'deepin-app-services'
19 'deepin-polkit-agent' 'deepin-polkit-agent-ext-gnomekeyring'
20 # accounts/keybinding/systeminfo
23 'fontconfig' 'noto-fonts'
26 # bin/backlight_helper
34 'deepin-session-ui' 'sudo'
36 'imwheel' 'libxkbfile' 'procps-ng' 'psmisc'
44 'mobile-broadband-provider-info' 'org.freedesktop.secrets' 'xdg-utils'
48 'dmidecode' 'libinput' 'lshw' 'upower'
50 'lsb-release' 'udisks2' 'util-linux')
51 makedepends=('golang-github-linuxdeepin-go-dbus-factory' 'golang-deepin-gir' 'golang-deepin-lib'
52 'golang-deepin-dde-api' 'golang-github-nfnt-resize' 'golang-gopkg-yaml.v3' 'sqlite'
53 'deepin-gettext-tools' 'golang-github-fsnotify-fsnotify' 'golang-github-stretchr-testify'
54 'git' 'mercurial' 'python-gobject' 'networkmanager' 'bluez' 'go')
55 optdepends=('networkmanager: for network management support'
56 'bluez: for bluetooth support'
57 'iw: for miracast module'
58 'proxychains-ng: for proxy configuration module')
59 conflicts=('dde-daemon')
60 replaces=('dde-daemon')
62 install="$pkgname.install"
63 source=("git+https://github.com/linuxdeepin/dde-daemon.git#commit=$_commit"
64 $pkgname-dpkg-architecture.patch::https://github.com/linuxdeepin/dde-daemon/commit/56b7a2010ab43fe73ee7456527d0792bb7220a35.patch
65 $pkgname-fix-vanilla-libinput.patch
66 'deepin-daemon.sysusers')
68 '87b7acca26338899316219daa300a83c6a2e94bd0f2bea372dfea50218187f81d010da7cd4b2049e1403357868e3394634358a5a7c8c3a7be6d5aa4f84bf8d65'
69 '944b0ae6cf7f613fd00884593c5e5f43aaf0efe4ea7aaa546a06b4367b8da4f2bc486dca640f77743bd1b7b9e4aacf741afe5c5e3ee219c2fdd4cc891ab3d367'
70 '808c02d4fec4cbbb01119bbb10499090199e738b7dd72c28a57dde098eef6132723f3434c151f79e21d9f788c7f7bae8046573ac93ba917afe0e803fbffa6d5a')
72 export GO111MODULE=off
76 patch -p1 -i ../$pkgname-fix-vanilla-libinput.patch
78 # Revert commit to use dpkg-architecture instead of pkg-config
79 patch -Rp1 -i ../$pkgname-dpkg-architecture.patch
81 export GOPATH="$srcdir/build:/usr/share/gocode"
83 go get github.com/cryptix/wav github.com/axgle/mahonia github.com/msteinert/pam github.com/gosexy/gettext github.com/rickb777/date \
84 github.com/jinzhu/gorm github.com/kelvins/sunrisesunset github.com/mozillazg/go-pinyin github.com/teambition/rrule-go \
85 golang.org/x/xerrors github.com/mattn/go-sqlite3 github.com/godbus/dbus google.golang.org/protobuf/proto \
86 github.com/Lofanmi/pinyin-golang/pinyin github.com/youpy/go-wav github.com/mdlayher/netlink
88 sed -i 's#/usr/share/backgrounds/default_background.jpg#/usr/share/backgrounds/deepin/desktop.jpg#' accounts/user.go
90 # https://github.com/linuxdeepin/developer-center/discussions/3327
91 sed -i 's#/usr/libexec#/usr/lib#' keybinding/shortcuts/system_shortcut.go
92 sed -i 's#${PREFIX}/libexec/#${PREFIX}/lib/#' Makefile
94 sed -i 's|"gopkg.in/yaml.v2"|"gopkg.in/yaml.v3"|' network/nm_generator/utils.go
96 sed -i 's|/etc/os-version|/etc/uos-version|' keybinding/shortcuts/shortcut_manager.go
100 export CGO_CPPFLAGS="${CPPFLAGS}"
101 export CGO_CFLAGS="${CFLAGS}"
102 export CGO_CXXFLAGS="${CXXFLAGS}"
103 export CGO_LDFLAGS="${LDFLAGS}"
104 export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
108 make -C network/nm_generator gen-nm-code
114 make DESTDIR="$pkgdir" PAM_MODULE_DIR=usr/lib/security install
116 mv "$pkgdir"{,/usr}/lib/systemd
117 mv "$pkgdir"{,/usr}/lib/udev
120 install -Dm644 ../deepin-daemon.sysusers "$pkgdir/usr/lib/sysusers.d/deepin-daemon.conf"