upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / devil / trunk / PKGBUILD
blob85592cd452af8f4c23bb8a06768371ecee679328
1 # Maintainer: Laurent Carlier <lordheavym@archlinux.org>
2 # Contributor: damir <damir@archlinux.org>
3 # Contributor: TheHoff <forums>
5 pkgname=devil
6 pkgver=1.8.0
7 pkgrel=8
8 pkgdesc="Library for reading several different image formats"
9 arch=('x86_64')
10 url="https://sourceforge.net/projects/openil/"
11 depends=('libpng' 'jasper' 'lcms2' 'libjpeg-turbo')
12 makedepends=('cmake')
13 options=('!docs' '!emptydirs')
14 license=('GPL')
15 source=(https://downloads.sourceforge.net/openil/DevIL-$pkgver.tar.gz
16         soversion.patch
17         jasper.patch)
18 sha256sums=('0075973ee7dd89f0507873e2580ac78336452d29d34a07134b208f44e2feb709'
19             'f6ef4b428fd68f0fb837af548d20ffa5ca96f3e8e4f57faca8f5a90dc48b0377'
20             'a3e1009e70be5a159250e3ea30d39f5aef1fa23eacece79e72deda51d7200159')
22 prepare() {
23   cd "${srcdir}/DevIL"
25   # Add solib version number to CMakeLists.txt
26   # https://github.com/DentonW/DevIL/pull/50
27   patch -Np1 -i "${srcdir}/soversion.patch"
28   # https://github.com/DentonW/DevIL/commit/42a62648e727e9a0217280474546de3ac69cbff1
29   patch -Np1 -i "${srcdir}/jasper.patch"
32 build() {
33   cd "${srcdir}/DevIL/DevIL"
35   rm -rf build && mkdir build
36   cd build
37   cmake .. \
38     -DCMAKE_INSTALL_PREFIX=/usr \
39     -DCMAKE_INSTALL_LIBDIR=lib
40   make  
43 package() {
44   cd "${srcdir}/DevIL/DevIL/build"
46   make DESTDIR="$pkgdir" install