1 # Maintainer: schuay <jakob.gruber@gmail.com>
2 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 # Contributor: Jeremy Newton (Mystro256) <alexjnewt@gmail.com>
6 pkgver=5.0.r18498.46b99671d9
9 pkgdesc='A Gamecube / Wii / Triforce emulator'
11 url=https://dolphin-emu.org
50 optdepends=('pulseaudio: PulseAudio backend')
52 _commit=46b99671d9158e0ca840c1d8ef249db0f321ced7
54 dolphin-emu::git+https://github.com/dolphin-emu/dolphin.git#commit=${_commit}
55 git+https://github.com/mozilla/cubeb.git
56 git+https://github.com/epezent/implot.git
57 git+https://github.com/randy408/libspng.git
58 git+https://github.com/RetroAchievements/rcheevos.git
59 git+https://github.com/arsenm/sanitizers-cmake.git
60 git+https://github.com/KhronosGroup/SPIRV-Cross.git
61 git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git
62 git+https://github.com/zlib-ng/zlib-ng.git
76 for submodule in Externals/{cubeb/cubeb,implot/implot,libspng/libspng,spirv_cross/SPIRV-Cross,VulkanMemoryAllocator,zlib-ng/zlib-ng}; do
77 git submodule init ${submodule}
78 git config submodule.${submodule}.url ../${submodule##*/}
79 git -c protocol.file.allow=always submodule update ${submodule}
81 cd Externals/cubeb/cubeb
82 git submodule init cmake/sanitizers-cmake
83 git config submodule.cmake/sanitizers-cmake.url "${srcdir}"/sanitizers-cmake
84 git -c protocol.file.allow=always submodule update cmake/sanitizers-cmake
89 git describe | sed 's/-/.r/; s/-g/./'
93 cmake -S dolphin-emu -B build -G Ninja \
94 -DCMAKE_BUILD_TYPE=None \
95 -DCMAKE_INSTALL_PREFIX=/usr \
96 -DDISTRIBUTOR=archlinux.org \
99 -DUSE_SHARED_ENET=ON \
105 DESTDIR="${pkgdir}" cmake --install build
106 install -Dm 644 dolphin-emu/Data/51-usb-device.rules -t "${pkgdir}"/usr/lib/udev/rules.d/
107 rm -rf "${pkgdir}"/usr/{include,lib/libdiscord-rpc.a}