upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / ffms2 / repos / community-x86_64 / PKGBUILD
blob7ef3d5b3140084ab1bf30db265a2c965738aae5f
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 pkgname=ffms2
4 pkgver=2.40
5 pkgrel=4
6 pkgdesc='A libav/ffmpeg based source library and Avisynth plugin for easy frame accurate access'
7 arch=(x86_64)
8 url=https://github.com/FFMS/ffms2
9 license=(GPL)
10 depends=(ffmpeg)
11 makedepends=(
12   avisynthplus
13   git
15 optdepends=(
16   'avisynthplus: AviSynth plugin'
17   'vapoursynth: VapourSynth plugin'
19 provides=(
20   avisynth-plugin-ffms2
21   libffms2.so
22   vapoursynth-plugin-ffms2
24 _tag=55c2af57f1bdc587ca98d2e28d3d764c00b3e13a
25 source=(git+https://github.com/FFMS/ffms2.git#tag=${_tag})
26 sha256sums=(SKIP)
28 prepare() {
29   cd ffms2
30   git cherry-pick -n 586d87de3f896d0c4ff01b21f572375e11f9c3f1
31   mkdir -p src/config
32   autoreconf -fiv
35 pkgver() {
36   cd ffms2
37   git describe --tags
40 build() {
41   cd ffms2
42   export CXXFLAGS="$CXXFLAGS $(pkg-config --cflags avisynth) -fpermissive"
43   ./configure \
44     --prefix=/usr \
45     --enable-avisynth \
46     --enable-shared \
47     --disable-static
48   make
51 package() {
52   make DESTDIR="${pkgdir}" -C ffms2 install
53   for s in {avi,vapour}synth; do
54     install -dm 755 "${pkgdir}"/usr/lib/$s
55     ln -s ../libffms2.so "${pkgdir}"/usr/lib/$s/
56   done
59 # vim: ts=2 sw=2 et: