1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
6 pkgdesc='A libav/ffmpeg based source library and Avisynth plugin for easy frame accurate access'
8 url=https://github.com/FFMS/ffms2
16 'avisynthplus: AviSynth plugin'
17 'vapoursynth: VapourSynth plugin'
22 vapoursynth-plugin-ffms2
24 _tag=55c2af57f1bdc587ca98d2e28d3d764c00b3e13a
25 source=(git+https://github.com/FFMS/ffms2.git#tag=${_tag})
30 git cherry-pick -n 586d87de3f896d0c4ff01b21f572375e11f9c3f1
42 export CXXFLAGS="$CXXFLAGS $(pkg-config --cflags avisynth) -fpermissive"
52 make DESTDIR="${pkgdir}" -C ffms2 install
53 for s in {avi,vapour}synth; do
54 install -dm 755 "${pkgdir}"/usr/lib/$s
55 ln -s ../libffms2.so "${pkgdir}"/usr/lib/$s/