1 # Maintainer: Jiachen YANG <farseerfc@gmail.com>
2 # Contributor: Henrik Hodne <henrik@hodne.io>
3 # Contributor: Ariel AxionL <axionl@aosc.io>
4 # AUR Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
7 pkgname=('ttf-fira-code' 'woff-fira-code' 'woff2-fira-code')
10 pkgdesc="Monospaced font with programming ligatures"
12 url='https://github.com/tonsky/FiraCode'
13 license=('custom:OFL')
15 source=("$pkgbase-$pkgver.zip::https://github.com/tonsky/FiraCode/releases/download/${pkgver}/Fira_Code_v${pkgver}.zip"
16 "LICENSE::https://raw.githubusercontent.com/tonsky/FiraCode/${pkgver}/LICENSE")
17 sha512sums=('7f71b34cce960bb5b90165505214d9effa7aa0b9e3ae3a7da37b900db54adbb30d1ff4b44f77c88fe0c7ddef45fc17ac6f05f08745fd26e1a298eeb61e6fddd3'
18 'bee6615aa2c8771ea9685a6de630eceb554c22920fd56379be460f461b27081de2d12e04298e4aecc76b733465730f3f3b602867abbc2df53105eb8ccf5475d2')
23 local fonts=(FiraCode*."$ext")
24 local installdir="${ext^^}"
26 # Prepare destination directory
27 install -dm755 "$pkgdir/usr/share/fonts/$installdir"
31 for font in "${fonts[@]}"; do
32 install -m644 "$font" "$pkgdir/usr/share/fonts/$installdir"
36 install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
39 for _pkgname in ${pkgname[@]}; do
40 eval "function package_$_pkgname() { _package $_pkgname; }"
43 # vim:set ts=8 sw=4 et: