upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / flint / repos / community-x86_64 / PKGBUILD
blobcd9b9062082cab5d77228f11ea98bb5730ebacf0
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Rémy Oudompheng <oudomphe@clipper.ens.fr>
3 # Contributor: Alessandro "jakedust" Andrioni <jakedust@gmail.com>
5 pkgname=flint
6 pkgver=2.9.0
7 pkgrel=1
8 pkgdesc='A C library for doing number theory'
9 arch=(x86_64)
10 url='http://www.flintlib.org'
11 license=(GPL)
12 depends=(mpfr ntl cblas)
13 makedepends=(cmake python)
14 source=(http://www.flintlib.org/flint-$pkgver.tar.gz)
15 sha256sums=('2fc090d51033c93208e6c10d406397a53c983ae5343b958eb25f72a57a4ce76a')
17 build() {
18   cmake -B build -S $pkgname-$pkgver \
19     -DCMAKE_INSTALL_PREFIX=/usr \
20     -DWITH_NTL=ON
21   cmake --build build
24 package() {
25   DESTDIR="$pkgdir" cmake --install build