upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / fluidd / repos / community-any / PKGBUILD
blobef73a04824be4f050881af7eff7883ea7c4adf4d
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 pkgname=fluidd
4 pkgver=1.23.5
5 pkgrel=1
6 pkgdesc='A free and open-source Klipper web interface for managing your 3d printer'
7 arch=(any)
8 url=https://docs.fluidd.xyz/
9 license=(GPL3)
10 makedepends=(
11   git
12   nodejs-lts-gallium
13   npm
15 optdepends=('ustreamer: webcam streaming support')
16 _tag=41d3e1866ed0b147ab5fec9783964987b5f3edbb
17 source=(git+https://github.com/fluidd-core/fluidd.git#tag=${_tag})
18 validpgpkeys=(4C717BDC0E452F5B13490409AB4C64C58BA9C3ED) # Pedro Lamas <pedrolamas@gmail.com>
19 b2sums=(SKIP)
21 pkgver() {
22   cd fluidd
23   git describe --tags | sed 's/^v//'
26 build() {
27   cd fluidd
28   npm install --frozen-lockfile
29   npm run build
32 package() {
33   install -dm 755 "${pkgdir}"/usr/share/webapps
34   cp -dr --no-preserve=ownership fluidd/dist "${pkgdir}"/usr/share/webapps/fluidd
37 # vim: ts=2 sw=2 et: