1 # Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
3 pkgname=freedesktop-docs
4 pkgver=20220526.af8e64a
6 pkgdesc="Specifications from freedesktop.org"
8 url="https://standards.freedesktop.org"
11 makedepends=('git' 'xmlto' 'docbook-utils' 'docbook-xsl' 'docbook-xml' 'docbook-sgml' 'python-gitpython' 'discount')
12 source=("git+https://gitlab.freedesktop.org/xdg/xdg-specs.git#commit=af8e64a9670c9eb1689a34eb76470cfbc9d1cea3"
13 "git+https://gitlab.freedesktop.org/xdg/default-icon-theme.git#commit=b3f1207ccff5ce0ab45ead38031f98fc1abe9731"
14 "git+https://gitlab.freedesktop.org/xdg/shared-mime-info.git#commit=fea642e9a88fffc8fb14793a5cbd6c4031d4271b"
15 "git+https://gitlab.freedesktop.org/xdg/sound-theme-spec.git#commit=b38cb3916fbb7243a3f4e78284d5613cc9321c8c"
16 "git+https://gitlab.freedesktop.org/xdg/startup-notification.git#commit=07237ff25d6171e1b548118442ddba4259a53ba5"
17 "git+https://gitlab.freedesktop.org/dbus/dbus.git#commit=b30c2c293d6c599adafca5b82cb7df6351ca2fa1"
18 "git+https://gitlab.freedesktop.org/mpris/mpris-spec.git#commit=51e5848f9f763864568db233bffe98e3cb72bf13")
29 # Commit date + short rev
30 echo $(TZ=UTC git show -s --pretty=%cd --date=format-local:%Y%m%d HEAD).$(git rev-parse --short HEAD)
35 for d in dbus default-icon-theme shared-mime-info sound-theme-spec startup-notification mpris-spec; do
39 ln -s /usr/bin/mkd2html "$srcdir"/discount-mkd2html
43 cd ./xdg-specs/web-export
44 # mpris requires python2
45 sed -i '/git:mpris/d' specs.idx
46 export PATH="$srcdir":$PATH
49 find public -name '*.proc' -delete #find a way to stop these being produced?
53 cd "$srcdir"/xdg-specs/public
54 install -d "$pkgdir"/usr/share/doc/freedesktop.org/
55 cp -r --no-preserve=ownership * "$pkgdir"/usr/share/doc/freedesktop.org/