upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / git-latexdiff / repos / community-any / PKGBUILD
blob47f7965937420198aba5d909bc16403570b4e4e7
1 # Maintainer: Santiago Torres-Arias <santiago@archlinux.org>
2 # Maintainer: Benjamin Chrétien <chretien at lirmm dot fr>
3 pkgname=git-latexdiff
4 pkgver=1.6.0
5 pkgrel=1
6 pkgdesc="Simple but very convenient wrapper around Git and latexdiff"
7 arch=('any')
8 url="https://gitlab.com/git-latexdiff/git-latexdiff"
9 license=('BSD')
10 makedepends=('asciidoc')
11 depends=('texlive-core' 'texlive-bin' 'git')
12 source=("https://gitlab.com/${pkgname}/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
13 sha256sums=('9026e97c454a60212b764e6416ab45ccd5d543cb178b79639ff6ed63d5a9394e')
15 build() {
16   cd "${srcdir}"/${pkgname}-"${pkgver}"
18   # we need to initialize an empty git repository so git-latexdiff can print
19   # its help message (as a step for making the manpage).
20   git init
21   make git-latexdiff.1
24 package() {
25   cd "${srcdir}"/${pkgname}-"${pkgver}"
27   install -m0755 -D git-latexdiff "${pkgdir}"/usr/bin/git-latexdiff
28   install -m0644 -D git-latexdiff.1 "${pkgdir}"/usr/share/man/man1/git-latexdiff.1
29   install -m0644 -D COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
31 # vim:set ts=2 sw=2 et: