upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / global / trunk / PKGBUILD
blob56fe910d6209cc553539fd63151d64d236314cb1
1 # Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
2 # Contributor: Fredy García <frealgagu at gmail dot com>
3 # Contributor: Randy Ramos <rramos1295 at gmail dot com>
4 # Contributor: Peter Vasil <mail@petervasil.net>
5 # Contributor: Lucas De Marchi <lucas.de.marchi@gmail.com>
6 # Contributor: Matthias Meulien <orontee@gmail.com>
8 pkgname=global
9 pkgver=6.6.9
10 pkgrel=1
11 pkgdesc='Source code tagging system'
12 arch=(x86_64)
13 url='https://www.gnu.org/software/global/'
14 license=(GPL)
15 depends=(libltdl perl python sqlite)
16 optdepends=(ctags emacs idutils python-pygments vim)
17 options=(!emptydirs !libtool)
18 validpgpkeys=("26F631B43D624A927E6F1C33969C3BE389DDA6EB")
19 source=("https://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz"{,.sig})
20 b2sums=('53b48a0aaa57160f5dc57c4096e91f2463c8ae1453b9f68b94639eeae1178d9fbe3bef3d75700ddfeeff4c47030f2a89ab4ae3a1b801ceb128cd3fb369ff0c14'
21         'SKIP')
23 prepare() {
24   cd $pkgname-$pkgver
25   sed -i 's/\.la/.so/g' gtags.conf.in
26   # Rename lid to lid-idutils to avoid a name collision with idutils from AUR
27   sed -i 's/usable("lid")/usable("lid-idutils")/g' "$pkgname/$pkgname.c"
30 build() {
31   cd $pkgname-$pkgver
32   autoreconf -fi
33   ./configure \
34     --prefix=/usr \
35     --with-exuberant-ctags=/usr/bin/etags \
36     --with-sqlite3 \
37     --with-universal-ctags=/usr/bin/ctags
38   make
41 check() {
42   make -C $pkgname-$pkgver -k check
45 package() {
46   cd $pkgname-$pkgver
48   make DESTDIR="$pkgdir" install
50   # Package the emacs script
51   install -d "$pkgdir/usr/share/emacs/site-lisp"
52   mv "$pkgdir/usr/share/gtags/gtags.el" \
53     "$pkgdir/usr/share/emacs/site-lisp/gtags.el"
55   # Package the vim scripts
56   install -d "$pkgdir/usr/share/vim/vimfiles/plugin"
57   mv "$pkgdir/usr/share/gtags/gtags.vim" \
58     "$pkgdir/usr/share/vim/vimfiles/plugin/gtags.vim"
59   mv "$pkgdir/usr/share/gtags/gtags-cscope.vim" \
60     "$pkgdir/usr/share/vim/vimfiles/plugin/gtags-cscope.vim"