1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-code-assistance
4 pkgver=3.16.1+r14+gaad6437
7 pkgdesc="Code assistance services for GNOME"
9 url="https://wiki.gnome.org/Projects/CodeAssistance"
11 depends=(libgee python-dbus python-gobject python-pylint python-pyflakes python-pycodestyle
12 python-lxml python-simplejson ruby-dbus ruby-sass)
13 makedepends=(intltool gobject-introspection llvm clang gjs go gnome-common git)
14 optdepends=('clang: Assistance for C and C++'
15 'gjs: Assistance for JavaScript'
16 'go: Assistance for Go')
18 _commit=aad6437571461d35fe86c34a97f264e9bd7720c3 # master
19 source=("git+https://gitlab.gnome.org/GNOME/gnome-code-assistance.git#commit=$_commit")
24 git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
29 NOCONFIGURE=1 ./autogen.sh
34 ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
35 --libexecdir=/usr/lib --disable-vala
36 export CGO_CPPFLAGS="${CPPFLAGS}"
37 export CGO_CFLAGS="${CFLAGS}"
38 export CGO_CXXFLAGS="${CXXFLAGS}"
39 export CGO_LDFLAGS="${LDFLAGS}"
40 export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
41 export GO111MODULE=off
47 make DESTDIR="$pkgdir" install