upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / gnome-flashback / trunk / PKGBUILD
blob2d691df9de3b501892a63b301fd1991a3555513f
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
3 pkgname=gnome-flashback
4 pkgver=3.46.0
5 pkgrel=2
6 pkgdesc='GNOME Flashback session'
7 arch=('x86_64')
8 url='https://wiki.gnome.org/Projects/GnomeFlashback'
9 license=('GPL')
10 depends=('gnome-bluetooth-3.0' 'gnome-panel' 'gnome-session' 'gnome-settings-daemon'
11          'gnome-themes-extra' 'libibus' 'libxkbfile' 'metacity' 'libcanberra')
12 makedepends=('python3')
13 optdepends=('gnome-backgrounds: Default background'
14             'gnome-control-center: System settings'
15             'network-manager-applet: Network management')
16 source=("https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
17         'gnome-flashback.pam')
18 sha256sums=('7a8d5c03310e4dfadd18a65e00a37741032afeea5418dd6804a975c4b0980045'
19             '7148b3b1773fa312d6cd14798338cc70cffb6df7504ff1787687edd0363138d2')
21 build() {
22   cd $pkgname-$pkgver
23   ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib/$pkgname \
24               --disable-schemas-compile --enable-compile-warnings=minimum
25   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
26   make
29 package() {
30   cd $pkgname-$pkgver
31   make DESTDIR="$pkgdir" install
33   # Install pam file for the screensaver
34   install -Dm644 ../gnome-flashback.pam "$pkgdir/etc/pam.d/gnome-flashback"