upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / gnome-passwordsafe / trunk / PKGBUILD
blob8d7e01906dd7723a648d423c513a8abe67b0c0fd
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
3 pkgname=gnome-passwordsafe
4 pkgver=7.3
5 pkgrel=2
6 pkgdesc="Password manager for GNOME which makes use of the KeePass v.4 format"
7 arch=(any)
8 url="https://gitlab.gnome.org/World/PasswordSafe"
9 license=(GPL3)
10 depends=(gtk4 libadwaita libpwquality python-gobject python-pykeepass python-pyotp python-cairo python-validators python-zxcvbn)
11 makedepends=(git gobject-introspection meson)
12 _commit=85d2ad2b0f472feca2ec4263709e0e1494ce9d80
13 source=("git+https://gitlab.gnome.org/World/PasswordSafe.git/#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17   cd PasswordSafe
18   git describe --tags | sed 's/-/+/g'
21 build() {
22   arch-meson PasswordSafe build
23   ninja -C build
26 check() {
27   meson test -C build
30 package() {
31   meson install -C build --destdir "$pkgdir"