1 # Maintainer: Anatol Pomozov
2 # Contributor: Knut Ahlers <knut at ahlers dot me>
7 pkgdesc="A strict formatter for Go language"
9 url="https://github.com/mvdan/gofumpt"
10 license=('BSD-3-Clause')
12 source=("${pkgname}-${pkgver}.tar.gz::https://github.com/mvdan/gofumpt/archive/v${pkgver}.tar.gz")
13 sha512sums=('84e5dfbdc9c35b9b0eb9734951140ebf0d1d76e7a11753864997295b83451f1ac54247a697f3d8ceb4afe4e7c4c259392c82af78849df97ef1608bef52240e5f')
16 cd "${srcdir}/${pkgname}-${pkgver}"
17 CGO_ENABLED=0 go build -trimpath -mod=readonly -modcacherw
21 cd "${srcdir}/${pkgname}-${pkgver}"
22 install -Dm755 -t "${pkgdir}/usr/bin" gofumpt